This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 208380 - Conflicts: openmotif-devel
Conflicts: openmotif-devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lesstif (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 05:09 EDT by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.95.0-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-01 03:59:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2006-09-28 05:09:28 EDT
lesstif-devel contains an explicit
Conflicts: openmotif-devel

1. This prevents packaging openmotif-devel outside of Fedora.
2. This doesn't make any sense for Fedora
Comment 1 Patrice Dumas 2006-09-28 06:08:04 EDT
Indeed. This was done at a time when I hoped for openmotif
to be shipped during FC6, even with conflict on devel.

I have a local fix, which should appear in 0.95.0-10, but 
I cannot rebuild without libGLw-devel. I am waiting for 
some days for libGLw-devel to appear in extras. If it takes 
too much time I'll rebuild without it as it is a this an unused
optional dependency. Tell me how much time you can wait.
Comment 2 Patrice Dumas 2006-10-01 03:59:43 EDT
libGLw-devel appeareed, and now lesstif has been rebuilt without
the conflict, it is fixed in 0.95.0-10.
Comment 3 Patrice Dumas 2007-01-01 20:33:01 EST
I have readded a versioned obsoletes instead of conflicts, to solve
Bug 221083:

Obsoletes: openmotif <=  2.3.0-0.2.1
for lesstif, and

Obsoletes: openmotif-devel <=  2.3.0-0.2.1
for lesstif-devel

Please tell me if you have any concern with that.
Comment 4 Patrice Dumas 2007-01-05 06:21:48 EST
Per Rex request, I removed 
Obsoletes: openmotif <=  2.3.0-0.2.1



To fix Bug 215560, I also added
Obsoletes: openmotif21 <= 2.1.30-17.1.1

I am not worried about disturbing 3rd party packaging with 
that change, however, but about breaking custom software
and packages that were linked against openmotif21

Note You need to log in before you can comment on or make changes to this bug.