Bug 2084006 - Blanks TTY with NVIDIA driver since f36 upgrade
Summary: Blanks TTY with NVIDIA driver since f36 upgrade
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://ask.fedoraproject.org/t/commo...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-11 08:01 UTC by Trystram
Modified: 2022-06-17 10:19 UTC (History)
22 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-16 14:57:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Trystram 2022-05-11 08:01:30 UTC
1. Problem description : 

Since upgrading to fedora 36 the TTY are blanks. the TTY works fine as I can log in blindly and my DE (i3) is then starting correctly and displays turn on.

When switching to TTY (ctrl + alt + Fn), the screens go blank then turn off (no signal). 

I found another user reporting this : https://www.reddit.com/r/Fedora/comments/ucnqet/fedora_36_nvidia_blank_ttys/


2. Kernel : 5.17.5-300.fc36.x86_64
here are the kernel boot options I use : rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 cgroup_enable=memory swapaccount=1

I will try using nouveau and report back.


3. Everything worked fine in f35 yesterday.


6. Are you running any modules that not shipped with directly Fedora's kernel?:

nvidia 510.68.02-1.fc36
nvidia driver, installed from rpmfusion repo, provided by the `akmod-nvidia` package.
I tried re-installing it.



I am not sure if `kernel` is the right component for this issue, let me know if i should change it !


Update : I tried removing nvidia-drm.modeset=1 from the kernel boot options but now it's stuck on " nvidia-modeset: Loading NVIDIA kernel Mode Setting Driver for Unix platorms 510.68.02" Same thing happens when removing the nouveau blacklist parameters

Comment 1 Trystram 2022-05-11 08:44:42 UTC
I tried to do the following : 
dnf remove *nvidia*
reboot
dnf install akmod-nvidia
reboot

now the TTY works but the driver don't work properly : i'm stuck in a low resolution mode, only one screen detected and it freezes after a few seconds. Only the driver seems to crash because i can still blindly type commands.

Comment 2 Trystram 2022-05-11 09:01:04 UTC
After a few reboots the driver works again but i'm back to the same inital problem: TTY are blanks, output only resumes when x.org is started

Comment 3 Javier Martinez Canillas 2022-05-16 14:57:09 UTC
This is a known issue with the Nvidia driver and there's nothing we can in the Fedora kernel:

https://ask.fedoraproject.org/t/no-virtual-terminal-vt-with-the-nvidia-driver/22440

Comment 4 Trystram 2022-05-17 06:29:43 UTC
(In reply to Javier Martinez Canillas from comment #3)
> This is a known issue with the Nvidia driver and there's nothing we can in
> the Fedora kernel:
> 
> https://ask.fedoraproject.org/t/no-virtual-terminal-vt-with-the-nvidia-
> driver/22440

Thanks for your answer ! Sorry I failed to find the other bug before filling this one.

Comment 5 Javier Martinez Canillas 2022-05-19 18:38:14 UTC
I've proposed the following workaround https://gitlab.com/cki-project/kernel-ark/-/merge_requests/1788.

TL; DR the kernel will choose to either register a platform device that binds to simpledrm or {efi,vesa}fb depending on whether nvidia-drm.modeset=1 is set or not.


Note You need to log in before you can comment on or make changes to this bug.