Bug 208401 - hal-gnome assumes fixed length strings (UI boo boo)
hal-gnome assumes fixed length strings (UI boo boo)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 08:41 EDT by Armijn Hemel
Modified: 2013-03-05 22:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-01 11:10:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of hal-gnome, showing interface error (57.11 KB, image/png)
2006-09-28 08:44 EDT, Armijn Hemel
no flags Details

  None (edit)
Description Armijn Hemel 2006-09-28 08:41:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; nl; rv:1.8.0.7) Gecko/20060918 Fedora/1.5.0.7-3.fc6 Firefox/1.5.0.7 pango-text

Description of problem:
The userinterface in hal-gnome assumes that strings are only a certain width. This clashes with some translations, where strings seem to be "cut off".

Version-Release number of selected component (if applicable):
hal-gnome-0.5.7.1-3.fc6

How reproducible:
Always


Steps to Reproduce:
1. n/a
2.
3.

Actual Results:
n/a

Expected Results:
n/a

Additional info:
What I've described happens when I leave the default font on 10 points. If I scale down to 8, the problem "dissappears". Of course, this should be solved differently. I will attach a screenshot.
Comment 1 Armijn Hemel 2006-09-28 08:44:45 EDT
Created attachment 137311 [details]
screenshot of hal-gnome, showing interface error

This screenshot shows that "Apparaattype:" can't be shown completely (the thing
between the red lines).
Comment 2 Matthias Clasen 2007-04-01 11:10:11 EDT
Seems to be fixed in current hal-device-manage

r for me. Please reopen if you still see this problem.

Note You need to log in before you can comment on or make changes to this bug.