Bug 208403 - Wrong smb.conf file on PDC (ldap) chapter
Wrong smb.conf file on PDC (ldap) chapter
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Deployment_Guide (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Prpic
ecs-bugs
http://www.redhat.com/docs/manuals/en...
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 09:09 EDT by Javier Barroso
Modified: 2011-02-14 14:28 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-06 17:54:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Javier Barroso 2006-09-28 09:09:25 EDT
Description of problem:
14.3.3.2 tells you about this configuration lines:
add user script = /usr/sbin/useradd -m %u
delete user script = /usr/sbin/userdel -r %u
add group script = /usr/sbin/groupadd %g 
delete group script = /usr/sbin/groupdel %g 
add user to group script = /usr/sbin/usermod -G %g %u
add machine script = \
 /usr/sbin/useradd -s /bin/false -d /dev/null \
 -g machines %u

I think smbldap-tools should be mentioned and smbldap-useradd like command
should then be used in those lines.


Version-Release number of selected component (if applicable):
rhel-rg(ES)-4-HTML-RHI (2004-09-30T17:13)

How reproducible:
After read the manual, no /usr/share/doc/samba-3.0.10/LDAP/smbldap-tools mentions

Steps to Reproduce:
1. Not applicable
2.
3.
  
Actual results:
You can't configure a ldap+samba server reading manual

Expected results:
You can configure a PDC using samba+ldap (with smbldap-tools)

Additional info:
Please, mail me if I don't need smbldap-tools to configure PDC on redhat.
Mencions to pam_ldap / nss_ldap are necessary too.
Comment 1 Don Domingo 2007-04-16 01:04:44 EDT
Hi Javier,

sorry for the delay on this. at present, bugs filed against pre-RHEL5 docs can
be processed only if they do not involve extensive writing (unless the content
is provided beforehand). 

at that, can you specify to me what needs to be corrected? please provide a link
to the content in question, so we can delete whatever is incorrect.

as for adding new content, i'll have to check if we have extra cycles for it.  

Regards,
Don
Comment 2 Don Domingo 2007-04-16 01:05:16 EDT
Hi Javier,

sorry for the delay on this. at present, bugs filed against pre-RHEL5 docs can
be processed only if they do not involve extensive writing (unless the content
is provided beforehand). 

at that, can you specify to me what needs to be corrected? please provide a link
to the content in question, so we can delete whatever is incorrect.

as for adding new content, i'll have to check if we have extra cycles for it.  

Regards,
Don
Comment 3 Javier Barroso 2007-04-16 02:25:22 EDT
Hi Don Domingo,

I read from
http://downloads.sourceforge.net/smbldap-tools/smbldap-howto_20060710.pdf?modtime=1152609023&big_mirror=0

At page 15 you can see scripts that you need. Note about path is not the same on
redhat installation.
Comment 4 Don Domingo 2007-04-16 03:59:17 EDT
Hi Javier,

i did a quick check of the LDAP section
(http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/ref-guide/ch-ldap.html)
and it looks like it already discusses pam_ldap and nss_ldap in that section.

also, i hope i'm not misunderstanding your request here, but when i checked RHN
i found that we don't ship smbldap-tools with RHEL4. unless you can verify
otherwise, i'm afraid i can't work on this any further as we normally don't
document tools payloaded by packages we don't officially ship.

in any case, i removed an erroneous link to the idealx.org website in the
"Useful Websites" section. 
Comment 5 Javier Barroso 2007-04-16 04:07:43 EDT
Please read on:
/usr/share/doc/samba-3.0.10/LDAP/README
and look up into:
/usr/share/doc/samba-3.0.10/LDAP/smbldap-tools/

# cat /etc/redhat-release
Red Hat Enterprise Linux ES release 4 (Nahant Update 4)
Comment 6 Don Domingo 2007-04-17 20:08:49 EDT
hi Javier,

thanks for clarifying this. just to verify: you want me to add a short
description of smbldap-tools and a sample smb.conf file containing the following
items?

<quote>
add user script = \
    /usr/share/doc/samba-<version>/LDAP/smbldap-tools/smbldap-useradd -m "%u"
  ldap delete dn = Yes
  delete user script = \
    /usr/share/doc/samba-<version>/LDAP/smbldap-tools/smbldap-userdel "%u"
  add machine script = \
    /usr/share/doc/samba-<version>/LDAP/smbldap-tools/smbldap-useradd -w "%u"
  add group script = \
    /usr/share/doc/samba-<version>/LDAP/smbldap-tools/smbldap-groupadd -p "%g"
  delete group script = \
    /usr/share/doc/samba-<version>/LDAP/smbldap-tools/smbldap-groupdel "%g"
  add user to group script = \
    /usr/share/doc/samba-<version>/LDAP/smbldap-tools/smbldap-groupmod -m "%u" "% g"
  delete user from group script = \
    /usr/share/doc/samba-<version>/LDAP/smbldap-tools/smbldap-groupmod -x "% u" "%g"
  set primary group script = \
    /usr/share/doc/samba-<version>/LDAP/smbldap-tools/smbldap-usermod -g "%g" "%u 
</quote>
Comment 7 Javier Barroso 2007-05-04 02:51:57 EDT
I finally installed smbldap-tools-0.9.1-1.2.el4.rf ( I don't remember from
where) and my smb.conf contains:

add machine script = /usr/sbin/smbldap-useradd -w "%u"
  add user script = /usr/sbin/smbldap-useradd -m "%u"
  delete user script = /usr/sbin/smbldap-userdel "%u"
  add group script = /usr/sbin/smbldap-groupadd -p "%g"
  delete group script = /usr/sbin/smbldap-groupdel "%g"
  add user to group script = /usr/sbin/smbldap-groupmod -m "%u" "%g"
  delete user from group script = /usr/sbin/smbldap-groupmod -x "%u" "%g"
  set primary group script = /usr/sbin/smbldap-usermod -g "%g" "%u"

I can't remember if I could use /usr/share/doc/.../LDAP version
Comment 8 Michael Hideo 2007-10-22 22:44:02 EDT
Removing automation notification
Comment 10 Douglas Silas 2010-09-06 11:28:58 EDT
Red Hat is unable to address this issue for documentation relating to the Reference Guide in Red Hat Enterprise Linux 4. Red Hat Enterprise Linux 5 is our primary area of focus for such updates and if applicable, we will consider this change for inclusion in that release.

Note You need to log in before you can comment on or make changes to this bug.