Bug 208415 - [kn_IN] OTF rules to be fixed - Priority A
[kn_IN] OTF rules to be fixed - Priority A
Status: CLOSED DUPLICATE of bug 216639
Product: Fedora
Classification: Fedora
Component: fonts-indic (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Parag Nemade
: i18n
Depends On:
Blocks: 208816
  Show dependency treegraph
 
Reported: 2006-09-28 10:07 EDT by Ramakrishna Reddy Yekulla
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 06:59:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ramakrishna Reddy Yekulla 2006-09-28 10:07:53 EDT
Description of problem:
The OTF rules need to be fixed in Kn_IN fonts (fonts-kannada)

Version-Release number of selected component (if applicable):
fonts-kannada-2.0.4-1
Pango-1.14.4-1
gedit-2.15.9-1.fc6
 
How reproducible:
Easily Reproducible, the following components are need, fontforge, scim as a
input method, preferably raw unicode input, gedit.

Steps to Reproduce:
1. Install the latest font-kannada, 2.0.4-1 and make sure you have the latest
scim, and up to date pango
2. Activate the SCIM input method and select RAW UNICODE
3. Input the following raw unicode values
  
Actual results:
Formations of complex conjucts not appearing properly, i.e combinations of Ligatures

Expected results:

The combination of |Any Consonent | + |Dependent Vowel Sign| must be smooth and
rendering should be proper. The OpenType Rules should be available for the font.

Additional info:

Any combination of the following 
|Any Consonant| + U0CC6 
|Any Consonant| + U0CCC
|Any Consonant| + U0CC1
|Any Consonant| + U0CC4
|Any Consonant| + U0CC7
|Any Consonant| + U0CC8
|Any Consonant| + U0CCA
|Any Consonant| + U0CCB
|Any Consonant| + U0CCD
Comment 1 Rahul Bhalerao 2006-10-17 06:29:38 EDT
Patch is submitted on #208816.
Comment 3 Parag Nemade 2006-11-27 02:16:58 EST
work has been already done in #208816 and fixes already appeared in new
fonts-kannada-2.0-9 release
Comment 4 Leon Ho 2006-11-27 06:59:58 EST
Marking duplicate of 216639. We have fixed it in FC devel - not planned to fix
it in FC6 updates as of yet.

*** This bug has been marked as a duplicate of 216639 ***

Note You need to log in before you can comment on or make changes to this bug.