Bug 208473 - build PowerNow-K8 as a built-in instead of a module
Summary: build PowerNow-K8 as a built-in instead of a module
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Brian Maly
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-28 19:38 UTC by Brian Maly
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-26 18:52:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Maly 2006-09-28 19:38:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.1) Gecko/20060313 Fedora/1.5.0.1-9 Firefox/1.5.0.1

Description of problem:
PowerNow-K8 is a built-in for x86_64 but is a module for i386. It should be a built-in for consistency (between arches and with RHEL5)

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.boot system
2. see that powernow is a module not built-in
3.

Actual Results:


Expected Results:


Additional info:

Comment 4 RHEL Product and Program Management 2006-10-11 15:05:00 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Jay Turner 2006-10-17 15:37:15 UTC
QE ack for RHEL4.5.

Comment 13 RHEL Product and Program Management 2007-03-22 00:01:42 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 14 RHEL Product and Program Management 2007-04-18 22:56:27 UTC
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.

Comment 15 Guy Streeter 2007-07-26 18:36:17 UTC
We have a customer complaing about the fact that the driver is built-in on
x86_64. They want to replace it with an external module, and can't do so because
it is built-in.

Can we go the other way, and instead of building it in for x86_64, make it a
module on i386?


Comment 16 Brian Maly 2007-07-26 18:51:37 UTC
The current plan is to make this a module for i386. Additional init script logic
will be needed to make this work out-of-the-box. The initial reason for this BZ
being filed was so things worked out-of-the-box. The current plan accomplishes both.


Note You need to log in before you can comment on or make changes to this bug.