Bug 208534 - FC6 eclipse-changelog package is missing epoch 1 to keep upgrade path
FC6 eclipse-changelog package is missing epoch 1 to keep upgrade path
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse-changelog (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kyu Lee
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-29 05:09 EDT by Matthias Saou
Modified: 2013-01-09 23:05 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.3.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 11:17:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2006-09-29 05:09:32 EDT
From the automated check script :

    eclipse-changelog
      FC4 > FC6 (1:2.0.1_fc-21 > 0:2.3.1-1.fc6)
      FC5-updates > FC6 (1:2.1.0_fc-2 > 0:2.3.1-1.fc6)

Since the epoch is always used for version comparison _before_ any of version
and release, the FC4 and FC5-updates packages will _always_ be considered newer
than the FC6 one, thus upgrading to FC6 will leave an older package on the
system if it was already present.

Please re-add the "Epoch: 1" to the package (yes, you're stuck with it forever)
and rebuild the package before FC6 final, thanks.
Comment 1 Ben Konrath 2006-09-29 10:08:08 EDT
Sorry, this is my fault. I re-wrote the spec file and missed the Epoch. Thanks
for pointing this out. The package is building with the fix right now.
Comment 2 Ben Konrath 2006-09-29 11:17:18 EDT
Ok, this is now fixed. Thanks again.

Note You need to log in before you can comment on or make changes to this bug.