Bug 208601 - Unable to connect to the admin server
Unable to connect to the admin server
Status: CLOSED NOTABUG
Product: 389
Classification: Community
Component: Directory Console (Show other bugs)
1.0.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Rich Megginson
Orla Hegarty
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-29 11:40 EDT by gangloff
Modified: 2007-04-18 13:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-09 18:33:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gangloff 2006-09-29 11:40:59 EDT
Description of problem:
I have installed Fedora Directory Server on Fedora CORE 5. Everything is
correct, except when I type the following command:

./startconsole -u admin -a http://pc-201.cesr.fr:10320

The Fedora Management console login is correctly displayed, but
I get the following message :
Exception in thread "http://pc-201.cesr.fr:10320/"
java.lang.UnsupportedOperationException: Thread.stop unimplemented
   at java.lang.Thread.stop (libgcj.so.7)
   at java.lang.Thread.stop (libgcj.so.7)
   at com.netscape.management.client.comm.HttpChannel.close (Unknown Source)
   at com.netscape.management.client.comm.CommManager.closeChannel (Unknown Source)
   at com.netscape.management.client.comm.HttpChannel.kill (Unknown Source)
   at com.netscape.management.client.comm.HttpChannel.run (Unknown Source)
   at java.lang.Thread.run (libgcj.so.7)

and a message in a pop-up window:
Cannot logon because of an incorrect User ID incorrect passwd or Directory problem
HTTP Exception
Response: HTTP/1.1 401 Authorization Required 
Status 401
URL: http://pc-201.cesr.fr:10320/admin-serv/authenticate



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.rpm -ivh fedora-ds-1.0.2-1.FC5.i386.opt.rpm
2./opt/fedora-ds/setup/setup
3../startconsole -u admin -a http://pc-201.cesr.fr:10320/
  
Actual results:
See above

Expected results:
The console window should be displayed

Additional info:
Comment 1 Rich Megginson 2006-09-29 12:41:33 EDT
You have to use Sun or IBM java.  gcj is not quite up to the task of running the
console yet.  See 
http://directory.fedora.redhat.com/wiki/Install_Guide#Java_is_required_for_the_console
Comment 2 gangloff 2006-10-02 05:27:07 EDT
(In reply to comment #1)
> You have to use Sun or IBM java.  gcj is not quite up to the task of running the
> console yet.  See 
>
http://directory.fedora.redhat.com/wiki/Install_Guide#Java_is_required_for_the_console
> 

I Do use the Sun JRE ( j2re1.4.2_12 )
JAVA_HOME=/usr/java/j2re1.4.2_12
Comment 3 Rich Megginson 2006-10-02 09:19:40 EDT
You can use Sun JRE.  You can also use IBM JRE.  Make sure the java command is
in your PATH.
Comment 4 gangloff 2006-10-02 09:27:19 EDT
(In reply to comment #3)
> You can use Sun JRE.  You can also use IBM JRE.  Make sure the java command is
> in your PATH.

Is'nt it enough to set JAVA_HOME  ie "export JAVA_HOME=/usr/java/j2re1.4.2_12" ?
Comment 5 Rich Megginson 2006-10-02 10:28:20 EDT
No.  You also have to make sure the correct version of java is in your PATH.

Note You need to log in before you can comment on or make changes to this bug.