Bug 208651 - [Regression] hal no longer announces wireless devices
[Regression] hal no longer announces wireless devices
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks: 205926
  Show dependency treegraph
 
Reported: 2006-09-29 17:07 EDT by Stefan Becker
Modified: 2013-03-05 22:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-28 19:39:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Becker 2006-09-29 17:07:37 EDT
Description of problem:

When I insert my Atheros-based (madwifi driver) PCMCIA WLAN card hal no longer
announces the ath0 device. Thus NetworkManager doesn't start scanning, etc. This
is a regression from the original FC6test3 installation.

Version-Release number of selected component (if applicable):

kernel-2.6.18-1.2699.fc6
hal-0.5.8.1-2.fc6
madwifi-0.9.2

How reproducible: Always


Steps to Reproduce:
1. Insert PCMCIA WLAN card
2. nm-tool
3.
  
Actual results: nm-tool doesn't show ath0 device

Expected results: nm-tool should show ath0 device and NetworkManager should
start scanning for wireless networks.


Additional info:

I tried an older FC6test3 kernel but the behaviour was the same. hal was updated
at least once since then. Madwifi wasn't updated.

lshal shows only the PCI device but not the network device:

$ diff -u hal-before.txt hal-after.txt
--- hal-before.txt      2006-09-29 23:51:18.000000000 +0300
+++ hal-after.txt       2006-09-29 23:51:47.000000000 +0300
@@ -1,5 +1,5 @@

-Dumping 91 device(s) from the Global Device List:
+Dumping 93 device(s) from the Global Device List:
 -------------------------------------------------
 udi = '/org/freedesktop/Hal/devices/computer'
   info.capabilities = {'cpufreq_control'} (string list)
@@ -433,6 +433,45 @@
   linux.sysfs_path_device = '/sys/devices/pci0000:00/0000:00:09.0'  (string)
   linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:09.0'  (string)

+udi = '/org/freedesktop/Hal/devices/pci_168c_13'
+  info.udi = '/org/freedesktop/Hal/devices/pci_168c_13'  (string)
+  linux.subsystem = 'pci'  (string)
+  linux.hotplug_type = 1  (0x1)  (int)
+  pci.subsys_product = 'Unknown (0xcb21)'  (string)
+  pci.subsys_vendor = 'AIRONET Wireless Communications'  (string)
+  info.product = 'AR5212 802.11abg NIC'  (string)
+  pci.product = 'AR5212 802.11abg NIC'  (string)
+  info.vendor = 'Atheros Communications, Inc.'  (string)
+  pci.vendor = 'Atheros Communications, Inc.'  (string)
+  pci.device_protocol = 0  (0x0)  (int)
+  pci.device_subclass = 0  (0x0)  (int)
+  pci.device_class = 2  (0x2)  (int)
+  pci.subsys_vendor_id = 5305  (0x14b9)  (int)
+  pci.subsys_product_id = 52001  (0xcb21)  (int)
+  pci.vendor_id = 5772  (0x168c)  (int)
+  pci.product_id = 19  (0x13)  (int)
+  info.linux.driver = 'ath_pci'  (string)
+  pci.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:09.0/0000:02:00.0' 
(string)
+  info.parent = '/org/freedesktop/Hal/devices/pci_1524_1410'  (string)
+  info.bus = 'pci'  (string)
+  linux.sysfs_path_device = '/sys/devices/pci0000:00/0000:00:09.0/0000:02:00.0'
 (string)
+  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:09.0/0000:02:00.0'  (string)
+
+udi = '/org/freedesktop/Hal/devices/net_00_40_96_a7_94_b1'
+  info.udi = '/org/freedesktop/Hal/devices/net_00_40_96_a7_94_b1'  (string)
+  linux.subsystem = 'net'  (string)
+  linux.hotplug_type = 2  (0x2)  (int)
+  info.product = 'Networking Wireless Control Interface'  (string)
+  net.arp_proto_hw_id = 801  (0x321)  (int)
+  net.linux.ifindex = 5  (0x5)  (int)
+  net.address = '00:40:96:a7:94:b1'  (string)
+  net.interface = 'wifi0'  (string)
+  net.physical_device = '/org/freedesktop/Hal/devices/pci_168c_13'  (string)
+  info.capabilities = {'net', 'net.80211control'} (string list)
+  info.category = 'net.80211control'  (string)
+  info.parent = '/org/freedesktop/Hal/devices/pci_168c_13'  (string)
+  linux.sysfs_path = '/sys/class/net/wifi0'  (string)
+
 udi = '/org/freedesktop/Hal/devices/pci_1106_3044'
   info.udi = '/org/freedesktop/Hal/devices/pci_1106_3044'  (string)
   linux.subsystem = 'pci'  (string)
@@ -1784,6 +1823,6 @@
   linux.sysfs_path = '/sys/devices/pnp0/00:0a'  (string)


-Dumped 91 device(s) from the Global Device List.
+Dumped 93 device(s) from the Global Device List.
 ------------------------------------------------

Output from dbus-monitor --system when you insert the card:

signal sender=org.freedesktop.DBus -> dest=:1.10 path=/org/freedesktop/DBus;
interface=org.freedesktop.DBus; member=NameAcquired
   string ":1.10"
signal sender=org.freedesktop.DBus -> dest=(null destination)
path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
   string ":1.11"
   string ""
   string ":1.11"
signal sender=org.freedesktop.DBus -> dest=(null destination)
path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
   string ":1.11"
   string ":1.11"
   string ""
signal sender=:1.2 -> dest=(null destination) path=/org/freedesktop/Hal/Manager;
interface=org.freedesktop.Hal.Manager; member=DeviceAdded
   string "/org/freedesktop/Hal/devices/pci_168c_13"
signal sender=:1.2 -> dest=(null destination) path=/org/freedesktop/Hal/Manager;
interface=org.freedesktop.Hal.Manager; member=DeviceAdded
   string "/org/freedesktop/Hal/devices/net_00_40_96_a7_94_b1"
signal sender=org.freedesktop.DBus -> dest=(null destination)
path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
   string ":1.12"
   string ""
   string ":1.12"
signal sender=org.freedesktop.DBus -> dest=(null destination)
path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
   string ":1.12"
   string ":1.12"
   string ""
signal sender=org.freedesktop.DBus -> dest=(null destination)
path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
   string ":1.13"
   string ""
   string ":1.13"
signal sender=org.freedesktop.DBus -> dest=(null destination)
path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
   string ":1.13"
   string ":1.13"
   string ""

Network device ath0 exists:

$ /sbin/ifconfig ath0
ath0      Link encap:Ethernet  HWaddr 00:40:96:A7:94:B1
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

$ /sbin/iwconfig ath0
ath0      IEEE 802.11b  ESSID:""
          Mode:Managed  Channel:0  Access Point: Not-Associated
          Bit Rate:0 kb/s   Tx-Power:0 dBm   Sensitivity=0/3
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=0/94  Signal level=-95 dBm  Noise level=-95 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Comment 1 Stefan Becker 2006-10-01 06:23:27 EDT
Downgrading hal and dbus to original FC6test3 versions didn't help.

When the PCMCIA WLAN card is present at boot time everything works OK, i.e. ath0
device is present in HAL information. If I remove and insert it again it doesn't
reappear.

What other components are involved in the hotplug of wireless devices? udev?
Comment 2 Matthew Miller 2007-04-06 13:31:56 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 3 Stefan Becker 2007-04-10 02:05:01 EDT
There has been no progress on this issue since fc6test3. Updated version field
accordingly.
Comment 4 Stefan Becker 2007-04-28 19:39:29 EDT
Retested with F7test4. Works fine again:

kernel-2.6.21-1.3116.fc7
hal-0.5.9-6.fc7
madwifi-0.9.3-2.fc6
udev-106-3.fc7
dbus-1.0.2-4.fc7
NetworkManager-0.6.5-1.fc7

Note You need to log in before you can comment on or make changes to this bug.