Bug 208663 - klogd gets 'stuck'
klogd gets 'stuck'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sysklogd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-29 18:11 EDT by Dave Jones
Modified: 2015-01-04 17:28 EST (History)
1 user (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-22 03:17:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-09-29 18:11:26 EDT
Every night at midnight, syslog stops logging the kernel ring buffer to
/var/log/messages.

I have to restart it by hand every morning.

klogd is still running.

if I strace it, I see it is still writing to fd 1 (socket:[82123])
Hmm, the action of strace'ing it also made it start spewing stuff to
/var/log/messages again.

I've noticed this because this is my firewall box, and usually, I see the
iptables messages in the daily mails from logwatch. Recently, that part of the
logwatch mails has been suspiciously absent.
Comment 1 Peter Vrabec 2007-03-06 06:17:59 EST
Does the problem still persist?
Comment 2 Dave Jones 2007-03-22 03:17:38 EDT
upgraded to fc6, haven't seen it since.

Note You need to log in before you can comment on or make changes to this bug.