Bug 208742 - Rescue/Install images do not contain dm-crypt module
Rescue/Install images do not contain dm-crypt module
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-01 08:52 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 11:33:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2006-10-01 08:52:16 EDT
Description of problem:
Not sure if this is the right component, please move if not.
Neither the rescue nor the regular install images seem to contain the dm-crypt
kernel module. It should be contained as there may be encrypted partitions to
deal with (and the cryptsetup program is already in the images).

Version-Release number of selected component (if applicable):
anaconda-11.1.0.102-1

How reproducible:
Always

Steps to Reproduce:
1. Boot current rescue environment
2. Try to use cryptsetup/load dm_crypt
3.
  
Actual results:
No dm_crypt module, cryptsetup fails to work

Expected results:
Ability to use encrypted partitions

Additional info:
Comment 1 Jeremy Katz 2006-10-01 18:53:22 EDT
Added the module, although not loading it automatically as we don't really
support dm-crypt much at all
Comment 2 Ralf Ertzinger 2006-10-02 04:12:16 EDT
That's fine with me. Thanks.

I thought I heard something about at least encrypted swap support in FC6 (via
/etc/crypttab).
Comment 3 Ralf Ertzinger 2006-10-04 04:05:15 EDT
Err, could you add some crypto modules, too? I personally just need aes at the
moment, but some choice might be appropriate.

Thanks!
Comment 4 Jeremy Katz 2006-10-04 11:33:08 EDT
The problem is what set to add.  Like you said, _you_ personally need aes.

Sorry, not going down this rathole.
Comment 5 Ralf Ertzinger 2006-10-04 11:39:59 EDT
Then you may as well remove dm-crypt (and cryptsetup) again, as they are pretty
useless without kernel crypto support.

Note You need to log in before you can comment on or make changes to this bug.