Bug 208759 - mysql.c:1608: internal compiler error: Segmentation fault
mysql.c:1608: internal compiler error: Segmentation fault
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gcc (Show other bugs)
4.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 208760 208761 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-01 14:30 EDT by anthony morris
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 03:14:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description anthony morris 2006-10-01 14:30:56 EDT
gcc -pipe -g -O2 -I/usr/include/mysql  -pthread -export-dynamic -I../include/ -
c             mysql.c
mysql.c:1608: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[1]: *** [mysql.o] Error 1
make[1]: Leaving directory `/home/celnix/anope-1.7.14/src'
make: *** [build] Error 2
[celnix@localhost anope-1.7.14]$ http://bugzilla.redhat.com/bugzilla
Comment 1 Tom Lane 2006-10-01 21:44:39 EDT
Reassigning to appropriate component ... although given the "not reproducible" report, I bet they're just 
gonna tell you you've got flaky hardware.
Comment 2 Tom Lane 2006-10-01 21:48:47 EDT
*** Bug 208760 has been marked as a duplicate of this bug. ***
Comment 3 Tom Lane 2006-10-01 21:50:05 EDT
*** Bug 208761 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Jelinek 2006-10-02 03:14:44 EDT
Unless you can reproduce it, always on the same file, same line, same error,
then you can just blame your hardware, not the compiler.  And the error message
strongly suggest that, the gcc driver has not been able to reproduce it in 3
subsequent attempts.

Note You need to log in before you can comment on or make changes to this bug.