Bug 208778 - yum can't see any extras packages in fc6 prerelease
yum can't see any extras packages in fc6 prerelease
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-01 18:55 EDT by Tom Horsley
Modified: 2014-01-21 17:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-06 11:07:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2006-10-01 18:55:59 EDT
Description of problem:

Something is rotten in repoland for the fc6 prelease. I've been
manually following things around to see if I could figure out why I
can seem to install anything from extras. I don't know why, but
here is what I find:

The /etc/yum.repos.d/fedora-extras-development.repo points to
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=extras-devel&arch=$basearch

If I manually visit that url (substituting x86_64 for $basearch) I get:

# repo = extras-devel country = US arch = x86_64 
http://download.fedoraproject.org/pub/fedora/linux/extras/development/$ARCH/
http://mirrors.kernel.org/fedora/extras/development/$ARCH/
http://fedora.cat.pdx.edu/linux/extras/development/$ARCH/
http://mirror.hiwaay.net/redhat/fedora/linux/extras/development/$ARCH/
http://mirrors.kernel.org/fedora/extras/development/$ARCH/

Picking the first one from the list and substituting x86_64 for $ARCH
I get a directory listing with a gazillion files, one of which shows
up as:

[ ]	yum-utils-0.6-5.fc6.noarch.rpm 	02-Aug-2006 14:31 	 54K

If I try to install yum-utils, I see this:

[root@zooty ~]# yum clean all
Loading "installonlyn" plugin
Cleaning up Everything
[root@zooty ~]# yum install yum-utils
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
development               100% |=========================| 1.1 kB    00:00     
extras-development        100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 1.0 MB    00:02     
################################################## 2931/2931
primary.xml.gz            100% |=========================| 1.0 MB    00:02     
################################################## 2931/2931
Parsing package install arguments
No Match for argument: yum-utils
Nothing to do
[root@zooty ~]# rpm -q yum-utils
package yum-utils is not installed

If I get back in the browser and visit the repodata directory I get a magic
page with repo info displayed in the browser and I can jump to the letter
Y and find this entry:

#  yum-utils-0.6-5.fc6: Utilities based around the yum package manager

So its there, why can't yum see it?


Version-Release number of selected component (if applicable):

yum-2.9.7-4

How reproducible:

Every time.

Steps to Reproduce:
1. try to install package from extras
2.
3.
  
Actual results:

yum says nothing to do

Expected results:

package installed

Additional info:

This is the fc6 DVD prelease image for x86_64 downloaded from the torrent.
I did do one round of "pup" updates, but pup says there aren't any updates
available now.
Comment 1 Jeremy Katz 2006-10-02 14:14:19 EDT
Seems to work for me here -- can you try with 'yum -d6'? 
Comment 2 Tom Horsley 2006-10-02 16:56:36 EDT
It works for me now as well. Something must have been wrong with a repo
or my connection to the repos last weekend. If I visit the mirrors list again,
I see more mirrors listed than I found before, and I can install extras
again. Off to install yumex so I don't have to use "pup" :-).
Comment 3 Tom Horsley 2006-10-02 19:30:03 EDT
Of course, it has now stopped working again (which must mean it is some
kind of repo or network problem). I know darn well "apcupsd" is in
extras, but if I try and install, this is what I see:

[root@zooty ~]# yum clean all
Loading "installonlyn" plugin
Cleaning up Everything
[root@zooty ~]# yum -d6 install apcupsd
Loading "installonlyn" plugin
Running "config" handler for "installonlyn" plugin
Yum Version: 2.9.8
COMMAND: yum -d6 
Installroot: /
Ext Commands:

   apcupsd
Setting up Install Process
Setting up repositories
development               100% |=========================| 1.1 kB    00:00     
extras-development        100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
Setting up Package Sacks
primary.xml.gz            100% |=========================| 1.0 MB    00:02     
################################################## 2931/2931
primary.xml.gz            100% |=========================| 1.0 MB    00:03     
################################################## 2931/2931
Reading Local RPMDB
Parsing package install arguments
Checking for virtual provide or file-provide for apcupsd
Searching pkgSack for dep: apcupsd
No Match for argument: apcupsd
Nothing to do

I also notice that when trying from yumex, it gives me feedback on populating
the install view that implies there are something like 1000 packages available.
I'm pretty sure when it was working there were more like 5000 (or maybe 7000)
available.
Comment 4 Tim Lauridsen 2006-10-03 09:43:31 EDT
This problem is caused by a bug in yum, the urls get accumulated across repos.

See this tread for more info.
https://lists.dulug.duke.edu/pipermail/yum-devel/2006-October/002701.html

The problem is fixed in Yum CVS by this patch.

https://lists.dulug.duke.edu/pipermail/yum-cvs-commits/2006-October/001065.html

a workaround is to clean metadata and use only one repo at a time

yum clean metadata
yum --disablerepo=\* --enablerepo=development update (this will work)

Comment 5 Tom Horsley 2006-10-04 07:58:24 EDT
Yep. I experienced the problem again last night, and was able to install
extras packages only by disabling all other repos first (after cleaning
the cache). A definite pain since some of the extras wanted packages
from the core, so I had to switch back and install them before
doing the remaining extras. I'm thinking this should be reopened until
the fix from upstream actually arrives in devel.
Comment 6 Rahul Sundaram 2006-10-04 10:03:33 EDT
Closing as per Tim Lauridsen's comments in fedora-test list. Thank you for the
bug report. 
Comment 7 Tim Lauridsen 2006-10-04 12:02:24 EDT
(In reply to comment #6)
> Closing as per Tim Lauridsen's comments in fedora-test list. Thank you for the
> bug report. 

I think it you misunderstood what is was writing on fedora-test list.

The problem still exist in yum-2.9.8-1 currently in rawhide.

It is fixed in yum CVS head, after yum-2.9.8 was released.

It is easy to reproduce the error:

#yum clean all
#yum list foobar

primary.xml.gz            100% |=========================| 1.1 MB    00:02     
################################################## 3501/3501
primary.xml.gz            100% |=========================| 1.1 MB    00:04     
################################################## 3501/3501

the extras metadata is loaded twice.

It should have been.

primary.xml.gz            100% |=========================| 825 kB    00:19     
################################################## 2241/2241
primary.xml.gz            100% |=========================| 1.1 MB    00:04     
################################################## 3501/3501




Comment 8 Tim Lauridsen 2006-10-06 11:05:19 EDT
This problem is now solved, yum 3.0.0 currently in rawhide.
Comment 9 Rahul Sundaram 2006-10-06 11:07:22 EDT
Thanks for the feedback. Closing. 

Note You need to log in before you can comment on or make changes to this bug.