Bug 208793 - Networking mismatch in /etc/hosts causes slow startup of certain X applications.
Networking mismatch in /etc/hosts causes slow startup of certain X applications.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-01 19:38 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 04:23:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-10-01 19:38:39 EDT
Description of problem:

This is a weird one. If my network is running (either wireless or wired...),
then a certain applications (gnomine, same-gnome, kdvi, oowriter, etc.) take a
lot longer to startup (30seconds to 2 minutes) while others are unchanged
(emacs, xdvi, gv, xpdf) in terms of starting up. Once they are running, there
appears to be no difference in how they operate. 

To reproduce:
1. ifup eth0
2. gnomine
3. ifdown eth0
4. gnomine

As far as I can tell, there are no messages in /var/log/messages that correspond
to when I start "gnomine". 

I tracked the problem to my /etc/hosts file. I had changed my hostname to be
laptop.localdomain (so I could see a unique name when I used bluetooth from my
cellphone) but had not manually updated /etc/hosts which still had
localhost.localdomain listed for 127.0.0.1. Once I manually updated /etc/hosts,
the slowdown at startup went away. 

My feeling is that there are two bugs somewhere here:
A) Whenever I update my hostname in the network configuration tool, it should
automatically adjust /etc/hosts as well

B) The time required to start up certain applications should not depend on what
/etc/hosts contains. If there is a connection, visible error messages should be
given to alert users as to the cause of the slowdown.

I am filing this bug against system-config-network because I don't know what the
common dependency that is causing (B) is.
Comment 1 Harald Hoyer 2006-10-02 04:23:20 EDT
A) Whenever I update my hostname in the network configuration tool, it should
automatically adjust /etc/hosts as well

It does...

B) X-Windows design!

Note You need to log in before you can comment on or make changes to this bug.