Bug 208845 - error using Add/Remove software - Exception - no more mirrors to try
error using Add/Remove software - Exception - no more mirrors to try
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pnm2ppa (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-02 08:58 EDT by peter young
Modified: 2013-01-10 03:57 EST (History)
0 users

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 14:44:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exception text (2.14 KB, text/plain)
2006-10-02 08:58 EDT, peter young
no flags Details

  None (edit)
Description peter young 2006-10-02 08:58:52 EDT
Description of problem:
When trying to add/remove program I get the attached error popup.


Version-Release number of selected component (if applicable):
pirut-1.1.8-1

How reproducible:
Always no packages are shown.
Usually the exception popup occurs aswell, but not always.

Steps to Reproduce:
1.Applications, Add/Remove Software
  
Actual results:
The exception popup occurs - see attachment

Expected results:
List of packages is shown


Additional info:
Comment 1 peter young 2006-10-02 08:58:52 EDT
Created attachment 137538 [details]
exception text
Comment 2 James Bowes 2006-10-09 14:29:56 EDT
It looks like yum is failing to download the repomd files, and since it is
unable to, it errors. pirut then displays a nasty traceback rather than a
friendly error message.

pirut 1.2.4 should have a fix for the error message.

not sure about the root cause of being unable to download the file, however.
Comment 3 peter young 2006-10-10 05:27:26 EDT
Now when I try Add/Remove Programs, that message does not appear so I get 
further 
Nothing is shown under browse

If I do Search, then check a package and do apply I get a popup:

Unable to verify (packagename)

when I click details I get

Public key for
(packagename)
is not installed

I have tried it for packages gftp and openssl097a

I get the same public key warning from yum, preceded by this line:

warning: rpmts_HdrFromFdno: Header V3 DSA signature: NoKEY, key ID 897da07a


How am I meant to do updates ?
Comment 4 James Bowes 2006-10-10 10:14:55 EDT
(In reply to comment #3)

> I get the same public key warning from yum, preceded by this line:
> 
> warning: rpmts_HdrFromFdno: Header V3 DSA signature: NoKEY, key ID 897da07a
> 
> 
> How am I meant to do updates ?

It looks like you just need to import the gpg keys. Running the following should
work:

find /etc/pki/rpm-gpg/ -name RPM-GPG* | xargs rpm --import
Comment 5 peter young 2006-10-10 10:25:36 EDT
thanks - that lets me do updates.
Will it be setup automatically in future ?

I still get no entries in the browse window of add/remove programs
Comment 6 James Bowes 2006-10-10 10:34:12 EDT
(In reply to comment #5)
> thanks - that lets me do updates.

You're welcome :)

> Will it be setup automatically in future ?

More automatically, anyways. yum/pup/etc will prompt you when its missing a gpg
key to import one, showing the the key signature. The idea here is that you can
verify that it is the correct key, so as to not compromise your system.

> 
> I still get no entries in the browse window of add/remove programs
> 

'browse' shows package groups. RHN does not have a concept of package groups,
which is why this screen is empty. the next release of pirut will notice that
there are no groups, and instead bring up the 'list' view by default.
Comment 7 peter young 2006-10-11 05:13:08 EDT
Thanks - I think that answers all, so you can close the case.

when I schedule a hardware refresh and do

rhn_check

I get 

Error refreshing system hardware" (code 12)

Is there a quick fix, - if not which component to I log this under ?

Note You need to log in before you can comment on or make changes to this bug.