Bug 208927 - Eclipse cannot start with feature.xml not found issue
Eclipse cannot start with feature.xml not found issue
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-02 13:22 EDT by Nurdin Premji
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 14:35:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file (1.90 KB, text/plain)
2006-10-02 13:22 EDT, Nurdin Premji
no flags Details

  None (edit)
Description Nurdin Premji 2006-10-02 13:22:38 EDT
Description of problem:

Latest version of eclipse cannot start as it cannot find a file called
feature.xml in
/usr/share/eclipse/features/org.eclipse.sdk_3.2.0.v20060609m-GpOJnQq-7es-zhF

may have something to do with the update now also having a directory:

/usr/share/eclipse/features/org.eclipse.sdk_3.2.1.r321_v20060801-Y2jCXB4kVIkGqHP


Version-Release number of selected component (if applicable):
eclipse-sdk-3.2.1-4.fc6

How reproducible:

Every time.

Steps to Reproduce:
1. Run Eclipse
2. Error message pops up saying view log.
3.
  
Actual results:
Eclipse doesn't start

Expected results:
Eclipse start

Additional info:
Comment 1 Nurdin Premji 2006-10-02 13:22:38 EDT
Created attachment 137570 [details]
Log file
Comment 2 Ben Konrath 2006-10-02 13:35:37 EDT
Please send me the output of these two commands:

 grep eclipse.product /usr/share/eclipse/configuration/config.ini
 rpm -qa | grep eclipse

Thanks.
Comment 3 Nurdin Premji 2006-10-02 13:47:31 EDT
grep eclipse.product /usr/share/eclipse/configuration/config.ini 
#eclipse.product=
# the identified eclipse.product defines the default application to run.

eclipse-jdt-sdk-3.2.1-4.fc6
eclipse-sdk-3.2.1-4.fc6
eclipse-pde-sdk-3.2.1-4.fc6
eclipse-rcp-sdk-3.2.1-4.fc6
eclipse-ecj-3.2.1-4.fc6
eclipse-rcp-3.2.1-4.fc6
eclipse-platform-sdk-3.2.1-4.fc6
eclipse-pde-3.2.1-4.fc6
eclipse-changelog-2.3.2-1.fc6
eclipse-jdt-3.2.1-4.fc6
eclipse-cdt-3.1.1-1.fc6
eclipse-platform-3.2.1-4.fc6
eclipse-pde-runtime-3.2.1-4.fc6
Comment 4 Andrew Overholt 2006-10-02 14:05:43 EDT
This is probably because Nurdin was upgrading between rawhide versions.  This
isn't supported and while we tried hard to make this work, we couldn't, due to
some errors in earlier packages that needed to be fixed.  A clean 'yum remove
eclipse-\*' and 'yum install eclipse-sdk' should fix things.
Comment 5 Ben Konrath 2006-10-02 14:13:46 EDT
Nurdin, just run this as root and you should be fine:

sed --in-place "s/#eclipse.product=/eclipse.product=org.eclipse.sdk.ide/" \
  /usr/share/eclipse/configuration/config.ini
Comment 6 Nurdin Premji 2006-10-02 14:32:07 EDT
That worked, thanks. (The later, didn't try out the former yet, but I will if I
get another eclipse error.)

Thank you all.

Note You need to log in before you can comment on or make changes to this bug.