Bug 208931 - sluggish response under high system load
sluggish response under high system load
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-02 13:49 EDT by Austin Foxley
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 17:42:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Austin Foxley 2006-10-02 13:49:51 EDT
Description of problem:
When compiz is enabled, and the cpu is pegged doing something (like parsing xml
on a yum update), the whole desktop interface slows to a crawl (mouse, moving
windows, dektop switching). Also, other apps slow down considerably (totem will
start to skip). 

Version-Release number of selected component (if applicable):
X Window System Version 7.1.1
Build ID: xorg-x11-server 1.1.1-43.fc6 

Steps to Reproduce:
1. Turn on "Desktop Effects"
2. Start a high cpu activity
3. Observe sluggish mouse
  
Actual results:
Slow response time for all actions

Expected results:
System load should not effect mouse or interface response.

Additional info:
This is on decently fast cpu, and a nvidia card (running the beta 9625 drivers).
My laptop (which has an integrated intel graphics chipset) doesn't have any
problems like this.

I realize this might just be the nvidia drivers causing trouble, but I figured I
should document it, because I know other people are having the same problem.
Comment 1 Adam Jackson 2007-07-27 17:42:04 EDT
Yeah, this is a general problem, and is therefore really hard to fix in the
general case.

If you have specific workloads that cause unreasonable CPU usage by the X server
itself, please file those.  But there's not much X can do if the kernel doesn't
give it enough CPU time.

Note You need to log in before you can comment on or make changes to this bug.