Bug 208950 - Rhythmbox crashes on changing "Browser view"
Rhythmbox crashes on changing "Browser view"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhythmbox (Show other bugs)
5.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-02 15:06 EDT by Michal Babej
Modified: 2013-07-31 19:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 06:14:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB backtrace of the crash (7.55 KB, text/plain)
2006-10-02 15:06 EDT, Michal Babej
no flags Details
Screenshot of started Rhythmbox (89.22 KB, image/png)
2006-10-03 11:14 EDT, Michal Babej
no flags Details
backtrace from bug-buddy (57.91 KB, text/plain)
2007-01-31 08:47 EST, Michal Babej
no flags Details

  None (edit)
Description Michal Babej 2006-10-02 15:06:55 EDT
Description of problem:
RhythmBox receives SIGSEGV after changing the "Browser views" at Preferences.

Version-Release number of selected component (if applicable):
rhythmbox-0.9.4.1-1.fc5.1.i386

How reproducible:
After some random experiments with RB UI (selecting different playlists from
different sources, and some playback) this occurs after changing "Browser view".
I managed to reproduce it at least 3 times - first time without gdb, then got 2
backtraces.

Steps to Reproduce:
Last step that causes crash is selecting another Browser view in preferences. I
will do further investigation on exact steps that cause the crash.
  
Actual results:
SIGSEGV

Expected results:
Normal operation

Additional info:
See attached GDB backtrace.
Comment 1 Michal Babej 2006-10-02 15:06:56 EDT
Created attachment 137588 [details]
GDB backtrace of the crash
Comment 2 Michal Babej 2006-10-03 11:13:10 EDT
starting conditions: in screenshot.

1. wait until library loads.
2. select library source.
3. select album.
4. select a song and press "play".
5. during playback, go to Edit menu and select Preferences.
6. in the Preferences dialog, select another "Browser view"
7. program receives SIGSEGV
Comment 3 Michal Babej 2006-10-03 11:14:34 EDT
Created attachment 137657 [details]
Screenshot of started Rhythmbox
Comment 4 Michal Babej 2006-10-17 09:59:28 EDT
changed version from FC5 to devel as this bug is still present in FC6-devel.
Comment 5 Matthias Clasen 2006-10-17 15:38:09 EDT
I can't reproduce this crash on my FC6 system.
Comment 6 Michal Babej 2006-10-20 03:11:52 EDT
Uhm, i tried it again and it crashed again. The whole library is .ogg music.
Does the backtrace make any sense ??
Comment 7 Michal Babej 2006-10-25 08:09:47 EDT
I have found this bug present in Mayhem. Can any1 try to reproduce and comment ??
Comment 8 Bastien Nocera 2007-01-30 18:10:55 EST
There are warnings before we get to the segfault:
(rhythmbox:4477): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT
(object)' failed

Could you please run rhythmbox with "--g-fatal-warnings" and gather a new
backtrace, please?
Comment 9 Michal Babej 2007-01-31 08:45:33 EST
with --g-fatal-warnings, it's output is:

GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
aborting...

and a backtrace from bugbuddy in attachment
Comment 10 Michal Babej 2007-01-31 08:47:04 EST
Created attachment 147019 [details]
backtrace from bug-buddy
Comment 11 Bastien Nocera 2007-02-05 06:27:04 EST
I can't reproduce this in FC6 either, so removing the FC6Update blocker.

Moving to RHEL5 where the problem might exist.
Comment 12 Bastien Nocera 2008-08-26 05:45:34 EDT
Please test with RHEL 5.3 when that's released.
Comment 13 Michal Babej 2009-02-04 07:08:23 EST
Can't reproduce in 5.3 (rhythmbox-0.11.6-4.el5)
Comment 14 Bastien Nocera 2009-02-13 06:14:13 EST
Good, closing.

Note You need to log in before you can comment on or make changes to this bug.