Bug 208959 - Following the kickstart of a Paravirtualization Host, the grub.conf needs to be automatically modified to use the Xen kernel.
Following the kickstart of a Paravirtualization Host, the grub.conf needs to ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn500-satellite-beta
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Wregglesworth
Brandon Perkins
:
: 208590 (view as bug list)
Depends On:
Blocks: 189917
  Show dependency treegraph
 
Reported: 2006-10-02 15:26 EDT by John Wregglesworth
Modified: 2007-04-18 13:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHN490
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-19 16:13:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Wregglesworth 2006-10-02 15:26:06 EDT
Description of problem: Right now, after a user kickstarts a machine to be a
paravirtualization host they need to modify the /etc/grub.conf file so that the
Xen kernel is used by default. We should do this automatically as part of the
paravirtualization host kickstart process, preferably in the %post section of
the kickstart.
Comment 1 John Wregglesworth 2006-10-02 15:48:32 EDT
*** Bug 208590 has been marked as a duplicate of this bug. ***
Comment 2 John Wregglesworth 2006-10-11 16:11:24 EDT
Fixed in SVN.

Test Plan.
1. On a 500-beta satellite, sync the beta channels (if necessary).
2. Subscribe a suitable virt-host to the satellite.
3. If necessary, create a virtualization-host kickstart profile.
4. Kickstart the system to the virtualization-host kickstart profile.
5. After the kickstart, check /etc/grub.conf and make sure that default=0 and
that the first entry is the xen kernel.
Comment 3 Brandon Perkins 2006-11-16 22:56:56 EST
Verified.  Grub file now looks like:

default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux Server (2.6.18-1.2747.el5xen)
        root (hd0,0)
        kernel /xen.gz-2.6.18-1.2747.el5 
        module /vmlinuz-2.6.18-1.2747.el5xen ro root=/dev/myvg/rootvol
        module /initrd-2.6.18-1.2747.el5xen.img
Comment 4 Brandon Perkins 2006-12-19 16:13:36 EST
Closed for RHN 500 Beta.

Note You need to log in before you can comment on or make changes to this bug.