This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 208974 - gfs needs to be added as selinux capable filesystem
gfs needs to be added as selinux capable filesystem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-02 16:06 EDT by Ryan O'Hara
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 20:00:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Add gfs to selinux policy (1021 bytes, patch)
2006-10-02 16:31 EDT, Ryan O'Hara
no flags Details | Diff

  None (edit)
Description Ryan O'Hara 2006-10-02 16:06:22 EDT
gfs is missing from the SELinux policy (filesystem.te). If I recall, both gfs
and gfs2 were once both identified as filesystems that support SELinux. This is
correct. Looks like only gfs2 is currently defined. Need this added to file
filesystem.te:

fs_use_xattr gfs gen_context(system_u:object_r:fs_t,s0);
Comment 1 Ryan O'Hara 2006-10-02 16:31:30 EDT
Created attachment 137599 [details]
Add gfs to selinux policy
Comment 2 Daniel Walsh 2006-10-05 15:43:29 EDT
Ryan can you remove the private checkbox so I can show this bugzilla to upstream
policy maintainance.

Comment 3 Daniel Walsh 2006-10-18 17:14:23 EDT
Fixed in selinux-policy-2.3.19-3
Comment 4 RHEL Product and Program Management 2006-10-18 21:33:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 6 RHEL Product and Program Management 2006-12-22 20:00:00 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.