Bug 208991 - Broken UTF-8 encoding
Broken UTF-8 encoding
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
medium Severity low (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-02 17:07 EDT by Ville Skyttä
Modified: 2013-06-23 22:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-30 23:14:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2006-10-02 17:07:23 EDT
Since some time ago, there appears to be some problems with Bugzilla's 
non-ASCII handling.

For an example, see bug 208990 (and probably this bug after I've submitted 
it): my surname displays as "Skyttä", not "Skyttä" as it should -> the 
trailing "ä" (lowercase "a" with umlaut) appears to be UTF-8 encoded twice or 
something.

I think this used to work fine about two months or so ago and before that as 
long as I can remember.  I haven't changed anything in my account.
Comment 1 Ville Skyttä 2006-10-02 17:08:36 EDT
The text I just submitted displays as it should here - only the "Opened by 
Ville Skyttä" string is affected.
Comment 3 David Lawrence 2008-09-16 12:54:54 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 4 David Lawrence 2008-11-30 23:14:59 EST
UTF8 handling in Bugzilla 3.2 is greatly improved over our older Bugzilla version. Please reopen this issue if the problem still occurs.

Note You need to log in before you can comment on or make changes to this bug.