Bug 209007 - Random installer hangs while installing RPMS
Random installer hangs while installing RPMS
Status: CLOSED DUPLICATE of bug 210072
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-02 17:54 EDT by Stewart Adam
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-09 17:00:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda's log when it hung on glibc-common (91.78 KB, text/plain)
2006-10-02 17:54 EDT, Stewart Adam
no flags Details

  None (edit)
Description Stewart Adam 2006-10-02 17:54:39 EDT
Description of problem:
I'm using the FC6 pre ISO's, and it twice out of the 3 times that Anaconda
hangs, 100% CPU, while installing packages. It happened on kdelibs the first
time, and glibc-common the second. 'top' just shows 98+% CPU usage for Anaconda,
and no further progress is made installing the packages. Time isn't an issue, as
I left to run overnight when it hung at kdelibs. No trace is produced, I had to
manually kill anaconda and reboot.

Version-Release number of selected component (if applicable):
fc6-pre iso's

How reproducible:
Sometimes

Steps to Reproduce:
1. Configure partitions, drives, etc
2. Let it install packages
3. See if it hangs
  
Actual results:
Anaconda hangs with 98+% cpu uage

Expected results:
The packages finish installing

Additional info:
I've attached anaconda.log that I copied to a floppy - There's a bunch of ERROR
messages about files existing - Maybe that's why?
Comment 1 Stewart Adam 2006-10-02 17:54:39 EDT
Created attachment 137604 [details]
Anaconda's log when it hung on glibc-common
Comment 2 Jeremy Katz 2006-10-02 18:05:28 EDT
Are there any error messages on tty4?
Comment 3 Stewart Adam 2006-10-03 13:02:34 EDT
No, that's the odd part. No errors on any tty, there's no trace of anything at
all besides that log I attached. Just Anaconda using lots of CPU. I wonder if I
can try reproducing it and using 'strace' that I put on my USB key to find out
more... 
Comment 4 Jeremy Katz 2006-10-04 11:35:14 EDT
Hmmm, strace might show something.  You can also do
  cd /tmp ; rpm2cpio /mnt/source/Fedora/RPMS/strace* |cpio -id
and then run /tmp/usr/bin/strace 

How much RAM do you have?
Comment 5 Stewart Adam 2006-10-04 17:10:44 EDT
256MB - That's more than enough, right? It's been installing Test 1,2,3 just fine...
Comment 6 Jeremy Katz 2006-10-05 10:49:59 EDT
Should be, although there seems to be something tickling lower memory installs.  
Comment 7 Jeremy Katz 2006-10-09 17:00:27 EDT

*** This bug has been marked as a duplicate of 210072 ***
Comment 8 Jim Cornette 2006-10-09 19:04:22 EDT
The 98% usage and no progress with the installation of packages seems very close
to the stall that I experienced. The package was inn both times where I saw this
failure using the text installer. Otherwise, a mee too.
Comment 9 Stewart Adam 2006-10-09 19:42:37 EDT
Hmmm... I don't recall it occuring on Inn, but it sure does sound like what
happened here...

Note You need to log in before you can comment on or make changes to this bug.