Bug 209014 - Network configuration for static IP needs a 'help' button
Network configuration for static IP needs a 'help' button
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-02 18:41 EDT by Stewart Adam
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 11:18:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2006-10-02 18:41:44 EDT
Description of problem:
When trying to configure static IP's in Anaconda, entering a netmask like
"255.255.255.0" causes a crash. I think this is because I'm entering the wrong
number, as the entry lines looks like this:
IPv4 Address [entry here] / [entry here] (netmask)
IPv6 Address [entry here] / [entry here] (netmask)

If I recall correctly, for firewalls you have to enter addresses like this:
0.1.2.3/24 or 0.1.2.3/16
, the /number being the netmask... But many people (including me) don't know
which is which. Maybe there should be a small 'help' button to define these?

Version-Release number of selected component (if applicable):
fc6-pre iso's

How reproducible:
Always

Steps to Reproduce:
1. Proceed through the installation steps like normal until reaching the
network/hostname configuration
2. Choose Static IP for eth0
3. Enter 255.255.255.0 as the netmask
  
Actual results:
A trace occurs

Expected results:
That it accepts 255.255.255.0 or that there's a help button to show what "/8",
"/16", "/24", or /32 represent

Additional info:
(Thanks for the great work on Anaconda 11!)
Comment 1 David Cantrell 2006-10-03 11:18:09 EDT
At what stage?  I've added either a text description or column headers that
explain what the input fields accept.

For stage1 (the text mode interface that comes up after it says Running
/sbin/loader...):

If you select manual network configuration, there is a text description at the
top of the dialog box that explains that you need to type in an IP address and
then either the prefix or dotted-quad netmask for IPv4.  For IPv6, you can only
enter a prefix.

For stage2 (after you see Starting anaconda, the Fedora Core installer...):

When configuring the network interfaces, if you do manual I have column headers
that say Address and Prefix (Netmask).  For IPv4, you can enter either a CIDR
prefix or a dotted-quad netmask.  They are the same thing, but I've added the
prefix ability to match what we need to gather for IPv6 addresses.  Dotted-quad
netmask notation is still supported since it's so common.

The input boxes validate either.  For a reference:
http://pintday.org/misc/cidr.shtml

I'm not going to add a help button that describes the prefix to netmask mappings
because we don't need that in the installer.  You can enter what you've always
entered and it will work.  But we have column labels and text descriptions,
which help people.
Comment 2 Stewart Adam 2006-10-03 16:46:08 EDT
Is the allowing the quad-dot new? Becuase that's what I entered that crashed the
installer...
Comment 3 David Cantrell 2006-10-03 16:49:43 EDT
No, dotted-quad has been the only accepted format before FC6.  I now take either
the dotted-quad netmask (e.g., 255.255.255.0) or CIDR prefix (e.g., /24) for IPv4.

You would see input validation problems on big-endian platforms, but that's been
fixed today.  If you were installing on Mac, for instance, it wouldn't take the
netmask or prefix correctly.

Note You need to log in before you can comment on or make changes to this bug.