Bug 209019 - Crash before installation starts on iMac G5
Crash before installation starts on iMac G5
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-02 19:04 EDT by Javier Cano
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 11.1.1.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-01 14:21:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Javier Cano 2006-10-02 19:04:40 EDT
Description of problem:

I can not install Fedora Core on an iMac G5 1.8 GHz (first version).

Version-Release number of selected component (if applicable):

Fedora Core 6 Test 3 installation process.

How reproducible:


Steps to Reproduce:
1. Start installation on iMac G5 1.8 GHz (first version).
2. The following message appears often during installation: "Attemp to read
sectors 0-127 outside of partition on /dev/sda". I select Ignore everytime.
3. When the system is ready to install I click on the continue button and the
system crashes and the bug report system appears. (I can not use the tool
because the wireless card has not been configured.)
  
Actual results:

System crashes. Then the system goes out of the installation process and reboots.

Expected results:

Instalation starts...
Additional info:
Comment 1 Will Woods 2006-10-05 23:35:47 EDT
We need more info to properly identify the problem. Could you copy the messages from when the installer 
crashed?

Do they include something about 'lvcreate'? There is a known bug with FC6t3 on the G5 when you use the 
default partition layout. It's due to a bug in LVM which has been fixed in the FC6-Prerelease images. (You 
can work around this problem by doing a custom partition scheme and not using LVM.)

The "Attempt to read sectors 0-127..." message is an unrelated problem that should be fixed for FC6.
Comment 2 Javier Cano 2006-11-01 13:15:37 EST
(In reply to comment #1)
> We need more info to properly identify the problem. Could you copy the
messages from when the installer 
> crashed?
> 
Hi!

The bug does not exist in Fedora Core 6. The system installs correctly. I have
not probed this old version again...

Greetings

> Do they include something about 'lvcreate'? There is a known bug with FC6t3 on
the G5 when you use the 
> default partition layout. It's due to a bug in LVM which has been fixed in the
FC6-Prerelease images. (You 
> can work around this problem by doing a custom partition scheme and not using
LVM.)
> 
> The "Attempt to read sectors 0-127..." message is an unrelated problem that
should be fixed for FC6.

Comment 3 Jarod Wilson 2006-11-01 14:21:06 EST
Closing, based on comment #2. Note that I believe this was actually an anaconda
bug, not a kernel bug. Altering component accordingly.

Note You need to log in before you can comment on or make changes to this bug.