Bug 209114 - Eclipse can't start
Eclipse can't start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-03 08:06 EDT by Tim Lauridsen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-06 14:44:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Lauridsen 2006-10-03 08:06:42 EDT
Description of problem:
Eclipse crashes on start on newly installed FC6 Prerelese + Rawhide updates.




Version-Release number of selected component (if applicable):
[root@localhost ~]# rpm -qa | grep eclipse
eclipse-bugzilla-0.2.4-3.fc6
eclipse-pde-3.2.1-4.fc6
eclipse-platform-sdk-3.2.1-4.fc6
eclipse-subclipse-1.1.5-2.fc6
eclipse-jdt-sdk-3.2.1-4.fc6
eclipse-sdk-3.2.1-4.fc6
eclipse-rcp-3.2.1-4.fc6
eclipse-ecj-3.2.1-4.fc6
eclipse-pde-runtime-3.2.1-4.fc6
eclipse-platform-3.2.1-4.fc6
eclipse-cdt-3.1.1-1.fc6
eclipse-jdt-3.2.1-4.fc6
eclipse-rcp-sdk-3.2.1-4.fc6
eclipse-changelog-2.3.2-1.fc6
eclipse-pde-sdk-3.2.1-4.fc6


How reproducible:

Everytime

Steps to Reproduce:
1. start 'Eclipse'
  
Actual results:
 Crash

Expected results:

Eclipse is starting.

Additional info:

Error in log.

!SESSION 2006-10-03 13:57:30.221 -----------------------------------------------
eclipse.buildId=M20060921-0945
java.fullversion=GNU libgcj 4.1.1 20060928 (Red Hat 4.1.1-28)
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86

!ENTRY org.eclipse.osgi 2 1 2006-10-03 13:57:34.442
!MESSAGE NLS missing message: fileInitializer_missingFileName in:
org.eclipse.core.internal.runtime.messages

!ENTRY org.eclipse.osgi 4 0 2006-10-03 13:57:34.444
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
   at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(org.eclipse.core.runtime_3.2.0.v20060603.jar.so)
   at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(org.eclipse.osgi_3.2.1.R32x_v20060919.jar.so)
   at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(org.eclipse.osgi_3.2.1.R32x_v20060919.jar.so)
   at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(org.eclipse.osgi_3.2.1.R32x_v20060919.jar.so)
   at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(org.eclipse.osgi_3.2.1.R32x_v20060919.jar.so)
   at java.lang.reflect.Method.invoke(libgcj.so.7rh)
   at org.eclipse.core.launcher.Main.invokeFramework(startup.jar.so)
   at org.eclipse.core.launcher.Main.basicRun(startup.jar.so)
   at org.eclipse.core.launcher.Main.run(startup.jar.so)
   at org.eclipse.core.launcher.Main.main(startup.jar.so)
Comment 1 Ben Konrath 2006-10-03 10:11:33 EDT
To fix this, edit /usr/share/eclipse/configuration/config.ini and change
"#eclipse.product=" to "eclipse.product=org.eclipse.sdk.ide". Thanks.
Comment 2 Ben Konrath 2006-10-03 11:10:53 EDT
*** Bug 209134 has been marked as a duplicate of this bug. ***
Comment 3 Andrew Overholt 2006-10-05 15:59:24 EDT
Does Ben's proposed fix work, Tim?  This was an issue between rawhide versions
and does not appear on FC5 -> FC6 updates or with fresh FC6 installations.
Comment 4 Tim Lauridsen 2006-10-06 03:07:32 EDT
I have added tthe eclipse.product and Eclipse starts without problems.

Thanks !!!
Comment 5 Andrew Overholt 2006-10-06 14:44:16 EDT
(In reply to comment #4)
> I have added tthe eclipse.product and Eclipse starts without problems.
> 
> Thanks !!!

No problem.  Thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.