This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 209162 - kdump fails if /dev/sdb1 is selected as the dump parittion in /etc/kdump.conf
kdump fails if /dev/sdb1 is selected as the dump parittion in /etc/kdump.conf
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
: 208310 209289 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-03 13:37 EDT by Nobuhiro Tachino
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-23 14:18:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
mkdumprd.diff (1.31 KB, patch)
2006-10-03 13:37 EDT, Nobuhiro Tachino
no flags Details | Diff
mkdumprd.diff 2 (1.28 KB, patch)
2006-10-03 13:40 EDT, Nobuhiro Tachino
no flags Details | Diff

  None (edit)
Description Nobuhiro Tachino 2006-10-03 13:37:24 EDT
Description of problem:

The kdump fails if /dev/sdb1 is selected as the dump partition in
/etc/kdumpl.conf. /dev/sda1 has no problem. The init script in
dump inird seems to fail to create the block device file for /dev/sdb1.

Version-Release number of selected component (if applicable):

kexec-tools-1.101-75

How reproducible:

Always

Steps to Reproduce:
1. add "ext3 /dev/sdb1" to /etc/kdump.conf
2. echo c > /proc/sysrq-trigger
3.
  
Actual results:

kdump script in dump initrd cannot find /dev/sdb1 and fails.

Expected results:

kdump succeeds.

Additional info:

init script in dump initrd creates incorrect device files for sdb. The following
is the output of 'ls -l /dev/sdb*' which is executed in shell session of initrd.

brw-r--r--    1 root     0          8,  16 Oct  2 14:18 /dev/sdb
brw-r--r--    1 root     0          8,  17 Oct  2 14:18 /dev/sdb17
brw-r--r--    1 root     0          8,  18 Oct  2 14:18 /dev/sdb18
brw-r--r--    1 root     0          8,  19 Oct  2 14:18 /dev/sdb19
brw-r--r--    1 root     0          8,  20 Oct  2 14:18 /dev/sdb20
brw-r--r--    1 root     0          8,  21 Oct  2 14:18 /dev/sdb21
brw-r--r--    1 root     0          8,  22 Oct  2 14:18 /dev/sdb22
brw-r--r--    1 root     0          8,  23 Oct  2 14:18 /dev/sdb23
brw-r--r--    1 root     0          8,  24 Oct  2 14:18 /dev/sdb24
brw-r--r--    1 root     0          8,  25 Oct  2 14:18 /dev/sdb25
brw-r--r--    1 root     0          8,  26 Oct  2 14:18 /dev/sdb26

Appended patch fixed this problem.
Comment 1 Nobuhiro Tachino 2006-10-03 13:37:24 EDT
Created attachment 137673 [details]
mkdumprd.diff
Comment 2 Nobuhiro Tachino 2006-10-03 13:40:42 EDT
Created attachment 137674 [details]
mkdumprd.diff 2

Sorry, the patch is reverted. I submit the correct one.
Comment 3 Neil Horman 2006-10-03 14:33:08 EDT
*** Bug 208310 has been marked as a duplicate of this bug. ***
Comment 4 Neil Horman 2006-10-04 07:40:44 EDT
*** Bug 209289 has been marked as a duplicate of this bug. ***
Comment 5 Jay Turner 2006-10-04 07:59:26 EDT
QE ack for 5b2 according to section 12c of the release criteria.
Comment 6 RHEL Product and Program Management 2006-10-04 08:02:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 7 Neil Horman 2006-10-04 11:08:50 EDT
fixed in -78.el5
Comment 8 Nobuhiro Tachino 2006-10-04 12:06:55 EDT
I confirmed kexec-tools-1.101-78 fixes the bug on my box.
Comment 11 Jay Turner 2006-10-23 14:15:55 EDT
Fix confirmed with 1.101-98.el5 which is part of the RHEL5-Server-20061020.1 trees.

Note You need to log in before you can comment on or make changes to this bug.