Bug 209203 - anaconda detects sound capability but reports unknown device
anaconda detects sound capability but reports unknown device
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-03 16:55 EDT by H Oudenhoven
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-22 16:15:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file created by anaconda during FC5 installation (6.04 KB, application/octet-stream)
2006-10-04 15:59 EDT, H Oudenhoven
no flags Details

  None (edit)
Description H Oudenhoven 2006-10-03 16:55:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

Description of problem:
Intel DP965LT motherboard. Installed FC5. No sound available. /root/scsound.log reports a lot of unknown devices, eg., 29a0,29a1,104b,2834,01df,6101 and many others.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Steps to Reproduce:
1. Install FC5 on Intel DP965LT motherboard
2.
3.

Actual Results:
No sound

Expected Results:
Sound

Additional info:
Comment 1 Martin Stransky 2006-10-04 09:12:10 EDT
please attach /root/scsound.log
Comment 2 H Oudenhoven 2006-10-04 15:59:16 EDT
Created attachment 137767 [details]
log file created by anaconda during FC5 installation
Comment 3 H Oudenhoven 2006-10-04 16:11:36 EDT
I presume this email got sent twice, the second time by mistake, as this appears
to be the second request for the same document, viz., scsound.log. The file
scsound.log has been sent to you as an attachment (#137767) to the previous
email. Regards, H. Oudenhoven.
P.S. In case I forget later, thank you for your support and quick response. I
appreciate it.
Comment 4 Martin Stransky 2006-10-05 04:28:53 EDT
Please check the latest drivers, how-to is here:

http://people.redhat.com/stransky/alsa/

btw. see message "aplay: main:547: audio open error: Device or resource busy"

It could be a problem with drives or your sound device may be used by another
application (like some sound server).
Comment 5 H Oudenhoven 2006-10-05 16:42:23 EDT
Checked out ALSA support page and downloaded
'kernel-devel-2.6.17-1.2187_FC5.i586.rpm and alsa-driver-1.0.13.tar.bz2'. The
former seemed to install without difficulty but the latter had difficulty with
the './configure'. It could not find
'/lib/modules/2.6.15-1.2054_FC5smp/source/include/version.h'. I checked the
directory and, sure enough, File Browser reported a broken link at
'/lib/modules/2.6.15-1.2054_FC5smp/source'. The file 'version.h' does exist,
however, at the newly created 'alsa-driver-1.0.13/include' directory. I presume
that is where the broken link is supposed to point. Question: how to fix the
broken link, if that is indeed the problem?
Regards, Harry.
Comment 6 Martin Stransky 2006-10-13 10:58:06 EDT
What kernel do you use? Have you installed the right kernel-devel package for
your current kernel? 

because kernel-devel-2.6.17-1.2187_FC5 isn't in /lib/modules/2.6.15-1.2054_FC5smp...
Comment 7 H Oudenhoven 2006-10-24 17:07:40 EDT
Hell Martin,

Sorry I didn't reply earlier; I've been on leave.

When I boot up the messages say: ... kernel: Linux version 2.6.15-1.2054_FC5smp

The system is precisely the one that is installed with the FC-5-i386
installation discs, apart from any changes that may have taken place when the
kernel-devel-2.6.17-1.2187_FC5.i586.rpm and alsa-driver-1.0.13.tar.bz2 were
installed as per your Comment #4 and my reply Comment #5.
Comment 8 Martin Stransky 2007-03-22 06:06:37 EDT
There's a new kernel update with alsa-drivers-1.0.14rc1 for FC-5. Please check
if it works for you.

Note You need to log in before you can comment on or make changes to this bug.