Bug 209303 - Jabberd fails to install cleanly due to selinux permission problems
Summary: Jabberd fails to install cleanly due to selinux permission problems
Status: CLOSED DUPLICATE of bug 175219
Alias: None
Product: Fedora
Classification: Fedora
Component: jabberd   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Reber
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-04 14:43 UTC by Wade Mealing
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-19 13:04:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wade Mealing 2006-10-04 14:43:05 UTC
Description of problem:

During the install procedure, selinux prevents the useradd utility (run by the
jabberd rpm) from writing to "lib"

Version-Release number of selected component (if applicable):

jabberd.i386 0:2.0-0.s11.11.fc6

How reproducible:

Every time.

Steps to Reproduce:
1. Install FC6 Devel (currentl rawhide)
2. yum install jabberd
3. Wait.
  
Actual results:

Downloading Packages:
(1/3): jabberd-2.0-0.s11. 100% |=========================| 556 kB    00:08     
(2/3): mysql-5.0.22-2.1.i 100% |=========================| 3.0 MB    01:09     
(3/3): perl-DBI-1.52-1.fc 100% |=========================| 605 kB    00:12     
Running Transaction Test
warning: mysql-5.0.22-2.1: Header V3 DSA signature: NOKEY, key ID 897da07a
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: perl-DBI                     ######################### [1/3] 
  Installing: mysql                        ######################### [2/3] 
warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                                               
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                                               
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                                               
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                                               
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                                               
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                                               
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                                               
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                                               
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                                               
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                                               
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                                               
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                      #                        
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                      #                        
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                      #                        
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                      #                        
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                      ######################## 
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                      ######################## 
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                      ######################## 
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                      ######################## 
[3/3]warning: user jabber does not exist - using root
warning: group jabber does not exist - using root
  Installing: jabberd                      ######################### [3/3] 
/bin/chown: `root.jabber': invalid user

Installed: jabberd.i386 0:2.0-0.s11.11.fc6
Dependency Installed: mysql.i386 0:5.0.22-2.1 perl-DBI.i386 0:1.52-1.fc6
Complete!

Expected results:

No errors during the install.


Additional info:

Seems fine if you manually add the user before hand, although the package is yet
untested.

Comment 1 Adrian Reber 2006-10-04 17:16:42 UTC
Any idea how this can be fixed? I never use selinux and I have therefore no clue
how to fix it.

Comment 2 Wade Mealing 2006-10-10 12:22:47 UTC
Well, I'd start by setting the context and permissions on the files.

Get a clean FC6 Install (current rawhide works mostly) then strart looking
through the logs for avc error messages, correct each one, either by chcon or
talking to the mailing list.

Rince and repeat the process till an install/remove does not complain anymore.

Comment 3 Sergio Pascual 2007-06-21 13:41:55 UTC
Perhaps this can be usefull: http://fedoraproject.org/wiki/PackageUserCreation

Comment 4 Adrian Reber 2007-06-21 13:58:42 UTC
Sorry, but I do not see how this link can be useful.

The problem here is that I am completely clueless when it comes to selinux and
have disabled selinux on all systems I am using.

So I am not able to fix this bug myself.

Comment 5 Sergio Pascual 2007-06-21 14:55:10 UTC
The bug appears during user creation with useradd, perhaps the method exposed in
PackageUserCreation can get around the problem

Comment 6 Sergio Pascual 2007-08-19 13:04:31 UTC

*** This bug has been marked as a duplicate of 175219 ***


Note You need to log in before you can comment on or make changes to this bug.