Bug 209318 - Display corruption with compiz, i965
Display corruption with compiz, i965
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
: 209256 (view as bug list)
Depends On:
Blocks: 212644
  Show dependency treegraph
 
Reported: 2006-10-04 12:05 EDT by Bill Nottingham
Modified: 2014-03-16 23:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 14:40:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen corruption. It gets worse if you move windows around. (1.19 MB, image/png)
2006-10-04 12:05 EDT, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2006-10-04 12:05:41 EDT
When using compiz, the display is corrupted on:

00:02.0 VGA compatible controller: Intel Corporation 965 G1 Integrated Graphics
Controller

Version-Release number of selected component (if applicable):

mesa-libGL-6.5.1-7.fc6
xorg-x11-server-Xorg-1.1.1-43.fc6
xorg-x11-drv-i810-1.6.5-9.fc6
compiz-0.0.13-0.31.20060817git.fc6

How reproducible:

Every time.

Steps to Reproduce:
1. Start X.
2. Start compiz
  
Actual results:

See attached.
Comment 1 Bill Nottingham 2006-10-04 12:05:42 EDT
Created attachment 137752 [details]
screen corruption. It gets worse if you move windows around.
Comment 2 Kristian Høgsberg 2006-10-04 12:33:54 EDT
*** Bug 209256 has been marked as a duplicate of this bug. ***
Comment 3 Kristian Høgsberg 2006-10-04 12:37:31 EDT
Looks like an i965 specific bug in mesa.  My guess is that ARB_texture_rectangle
computes the wrong texture coordinates for the lower left corner of the texture,
which looks like it's identical to the upper left corner.

Here's the mesa commit that implements ARB_texture_rectangle:

http://gitweb.freedesktop.org/?p=users/krh/mesa.git;a=commitdiff;h=2397cde37f16e5673cb965098f2a01c18641b305;hp=c326a261b81e3075515e50822c70d5c9aacb2b60

It was comitted after the 6.5.1 release and we backported it in mesa-6.5.1-6.fc6.
Comment 4 German Monroy 2006-10-10 21:07:08 EDT
I was able to reproduce in x86_64 but not in 386.

I am running both architecture in the same 965 system.  Therefore I dare to say
it is 64-bit specific.

We are having the same problem in SLED10.  See:
https://bugs.freedesktop.org/show_bug.cgi?id=8277
Comment 5 German Monroy 2006-10-11 12:33:58 EDT
FYI:  Keith Whitwell is engaged in helping us fix this problem upstream. 
Hopefully we'll soon get some code to try.
Comment 6 Kristian Høgsberg 2006-10-13 14:05:28 EDT
(In reply to comment #5)
> FYI:  Keith Whitwell is engaged in helping us fix this problem upstream. 
> Hopefully we'll soon get some code to try.

Sounds great, thanks for posting the upstream bug link.
Comment 7 German Monroy 2006-10-16 17:08:12 EDT
No problem, Kristian.

This bug has been fixed upstream.

The patch that fixes it (1 line long!) is the diff for Rev 1.2 of:
http://webcvs.freedesktop.org/mesa/Mesa/src/mesa/drivers/dri/i965/brw_draw_upload.c

I tested applying this patch on rawhide as of today and it worked.
Comment 8 Adam Jackson 2006-10-31 14:40:48 EST
This is fixed in both RHEL-5 and rawhide, and I'm currently building the update
for FC6.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.