Bug 209321 - blktap does not build on ia64
blktap does not build on ia64
Status: CLOSED DUPLICATE of bug 212315
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Aron Griffis
Brian Brock
:
Depends On: 208895
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-04 12:15 EDT by Stephen Tweedie
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-03 13:38:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2006-10-04 12:15:03 EDT
+++ This bug was initially created as a clone of Bug #208895 +++

Description of problem:
The kernel/drivers/xen/blktap/blktap.ko module does not build on ia64:

drivers/xen/blktap/blktapmain.c: In function 'fast_flush_area':
drivers/xen/blktap/blktapmain.c:902: error: implicit declaration of function
'create_lookup_pte_addr'

Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-1.2724.fc6.ia64

blktap has been disabled on ia64 for now:
$ grep TAP configs/*xen*
configs/config-xen-generic:CONFIG_XEN_BLKDEV_TAP=m
configs/config-xen-ia64:# CONFIG_XEN_BLKDEV_TAP is not set

-- Additional comment from chrisw@redhat.com on 2006-10-02 11:29 EST --
Created an attachment (id=137553)
blktap compile fix for ia64


-- Additional comment from chrisw@redhat.com on 2006-10-02 11:36 EST --
Here is a patch that gets things building.  It's a bit of a hack since
it copies create_lookup_pte_addr into ia64 specific source files.  With
this patch the thing builds, and boots.  However each of the blkback, netback
and blktap fail with the same error.  Basically none of the backend drivers are
working on ia64, they each fail in balloon_alloc_empty_page_range() due to
failed __get_free_pages() attempt with large order.

-- Additional comment from sct@redhat.com on 2006-10-02 12:15 EST --
Yes; the backend allocating issue is already being tracked as bug 202971.

-- Additional comment from chrisw@redhat.com on 2006-10-02 12:20 EST --
OK, in that case we could apply the blktap fix to get things working to a point
that they can be debugged.

-- Additional comment from prarit@redhat.com on 2006-10-04 12:00 EST --
Assigning to agriffis.
Comment 1 Aron Griffis 2006-11-03 13:38:16 EST

*** This bug has been marked as a duplicate of 212315 ***

Note You need to log in before you can comment on or make changes to this bug.