Bug 209322 - Dnd evolution componets on menus to Desktop, the components's link is broken.
Dnd evolution componets on menus to Desktop, the components's link is broken.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-04 12:18 EDT by sangu
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-28 01:53:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2006-10-04 12:18:02 EDT
Description of problem:
Dnd evolution componets on menus to Desktop, the components's link is broken.

Version-Release number of selected component (if applicable):
2.8.0-7.fc6

How reproducible:
always

Steps to Reproduce:
1. click gnome menu.
2. Click Office or Internet menu
3. Dnd a evolution component to Desktop.

  
Actual results:
the evolution component doesn't start on desktop 

Expected results:


Additional info:
redhat-menus-6.7.5-3
Comment 1 Matthew Barnes 2006-10-04 13:46:29 EDT
Thanks for the bug report.

It looks like the evolution .desktop files are symbolic links, and their targets
are relative paths.  They should probably be absolute paths instead so that the
links can be copied elsewhere.

/usr/share/applications/redhat-evolution-calendar.desktop ->
../desktop-menu-patches/redhat-evolution-calendar.desktop
/usr/share/applications/redhat-evolution-contacts.desktop ->
../desktop-menu-patches/redhat-evolution-contacts.desktop
/usr/share/applications/redhat-evolution-mail.desktop ->
../desktop-menu-patches/redhat-evolution-mail.desktop
/usr/share/applications/redhat-evolution-tasks.desktop ->
../desktop-menu-patches/redhat-evolution-tasks.desktop
Comment 2 Matthew Barnes 2006-10-04 14:20:16 EDT
Oops, this happens in evolution's spec file, not redhat-menus.

Changing component back to evolution.
Comment 3 sangu 2006-10-28 01:53:35 EDT
This problem is fixed in evolution-2.8.1.1-3.fc6. 

Note You need to log in before you can comment on or make changes to this bug.