Bug 209358 - kdump saves vmcore under the directory which has wrong date
kdump saves vmcore under the directory which has wrong date
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-04 16:04 EDT by Nobuhiro Tachino
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-13 12:10:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add clock adjustment to init script (885 bytes, patch)
2006-10-05 08:01 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Nobuhiro Tachino 2006-10-04 16:04:17 EDT
Description of problem:

When hardware clock is set as localtime, kdump saves vmcore under th directory
which has a wrong date. This is not the same bug as BZ#209189.

Version-Release number of selected component (if applicable):

kexec-tools-1.101-78

How reproducible:

Always.

Steps to Reproduce:
1. set hardware clock to localtime.
2. set the UTF option to false in /etc/sysconfig/clock.
3. execute kdump.
  
Actual results:

Tha panic occured at localtime 12:37. The actual directory is the following:

# ls -l /var/crash
total 4
drwxr-xr-x 2 root root 4096 Oct  4 08:37 127.0.0.1-2006-10-04-08:37:25

Expected results:

The directory name and timestamp should be the following.

# ls -l /var/crash
total 4
drwxr-xr-x 2 root root 4096 Oct  4 12:37 127.0.0.1-2006-10-04-12:37:25

Additional info:

In the regular init sequence, hwclock correct the system time, but the init
script in dump initrd does not do this. I think this is the cause of the bug.
Comment 1 Neil Horman 2006-10-05 08:01:33 EDT
Created attachment 137813 [details]
patch to add clock adjustment to init script

I think your right.  Please try this patch to see if it corrects the problem.
Comment 2 Nobuhiro Tachino 2006-10-05 15:29:46 EDT
-hctosys option required one more dash, but after it was fixed, the patch worked
fine. I confirmed it works on both localtime and UTC. Thanks!
Comment 3 Neil Horman 2006-10-05 16:04:23 EDT
fixed in -83.el5.  Thanks!
Comment 4 Jay Turner 2007-02-13 12:10:27 EST
kexec-tools-1.101-164.el5 included in 20070208.0.

Note You need to log in before you can comment on or make changes to this bug.