Bug 209376 - Selinux policy prevents upgrade of selinux policy rpm
Selinux policy prevents upgrade of selinux policy rpm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-04 17:58 EDT by Stephen Tweedie
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-05 08:58:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Tweedie 2006-10-04 17:58:55 EDT
Description of problem:
selinux-policy-targeted prevents successful RPM upgrades of itself.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.3.18-2
updating to selinux-policy-targeted-2.3.18-3

Steps to Reproduce:
1. Install rawhide with selinux-policy-targeted-2.3.18-2
2. rpm -Uvh selinux-policy-2.3.18-2 selinux-policy-targeted-2.3.18-2

Actual results:
Preparing...                ########################################### [100%]
   1:selinux-policy         ########################################### [ 50%]
   2:selinux-policy-targeted########################################### [100%]
libsemanage.semanage_commit_sandbox: Could not remove previous backup
/etc/selinux/targeted/modules/previous.
semodule:  Failed!
audit(1159998887.398:15): avc:  denied  { rmdir } for  pid=3640 comm="semodule"
name="modules" dev=dm-5 ino=950295
scontext=root:system_r:semanage_t:s0-s0:c0.c255
tcontext=system_u:object_r:selinux_config_t:s0 tclass=dir

Expected results:
No errors.
Comment 1 Daniel Walsh 2006-10-05 07:45:55 EDT
This means you have a labeling problem.  

restorecon -R -v /etc/selinux/targeted
Comment 2 Stephen Tweedie 2006-10-05 07:59:53 EDT
This was immediately after a reboot with /.autorelabel set, so if things were
relabeled, it was the SELinux policy's fault.  I'm also not sure what info
you're asking for.
Comment 3 Daniel Walsh 2006-10-05 08:58:48 EDT
Looks like the relable was unsuccessfull

Note You need to log in before you can comment on or make changes to this bug.