Bug 209393 - [GCJ bug] extension points don't work with gcj
[GCJ bug] extension points don't work with gcj
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-04 21:46 EDT by Ben Konrath
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 3.2.1-21.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-22 16:50:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 29853 None None None Never

  None (edit)
Description Ben Konrath 2006-10-04 21:46:56 EDT
Description of problem:

PDE shows errors in the plugin.xml for plugins that define extensions to their
own extension points.

Version-Release number of selected component (if applicable):

eclipse-sdk-3.2.1-4.fc6
gcc-java-4.1.1-28

Steps to Reproduce:
1. check out any plugin that define extensions to their own extension points - 
   I'm using update.core
2. see errors in plugin.xml
Comment 1 Andrew Overholt 2006-10-05 15:58:17 EDT
This is a problem with org.eclipse.update only AFAICT because ChangeLog uses
this and it works fine for me.
Comment 2 Andrew Overholt 2006-10-06 15:17:14 EDT
(In reply to comment #1)
> This is a problem with org.eclipse.update only AFAICT because ChangeLog uses
> this and it works fine for me.

I was wrong.  I started a clean workspace and this is happening to me with
ChangeLog and Bugzilla now.
Comment 3 Ben Konrath 2006-10-13 14:40:56 EDT
I just noticed that if you start eclipse with GCJ, build your project and then
restart with a propietary vm the problem is still around. You have to rebuild
the project before the problem is fixed. Andrew, this might be what you hit.
Comment 4 Ben Konrath 2006-10-13 14:42:52 EDT
Upping priority as this bug makes pde useless with GCJ.
Comment 5 Ben Konrath 2006-11-15 15:58:25 EST
I tracked this down to this bug:

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=29853
Comment 6 Ben Konrath 2006-11-22 16:50:15 EST
This is fixed in updates-testing. Closing bug.

Note You need to log in before you can comment on or make changes to this bug.