This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 209400 - Bind Init Script does not create the PID file always + fix
Bind Init Script does not create the PID file always + fix
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-05 01:42 EDT by Jeff Means
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-05 07:17:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
file makes sure a PID is wriiten out to $ROOTDIR/var/run/named/named.pid before reporting sucess (7.15 KB, text/plain)
2006-10-05 01:42 EDT, Jeff Means
no flags Details

  None (edit)
Description Jeff Means 2006-10-05 01:42:59 EDT
Description of problem:
When killing / restarting bind (aka named) the init script will fail due to
there not being a file correctlly linked in var/run/ (named.pid)

Version-Release number of selected component (if applicable):
FC4 - FC5

How reproducible:
If running with out SE Linux it will fail to restart the named daemon as it will
not shut down the running daemon.

Steps to Reproduce:
1. Start bind / named in chroot jail (tested w/o using SE Linux)
2. init script will fail to make the file $ROOTDIR/var/run/named/named.pid but
will make the symlink /var/run/named.pid to $ROOTDIR/var/run/named/named.pid
3.
  
Actual results:
file /var/run/named.pid exists as a broken symlink

Expected results:
file /var/run/named.pid contains the PID of the running bind daemon

Additional info:
Comment 1 Jeff Means 2006-10-05 01:42:59 EDT
Created attachment 137802 [details]
file makes sure a PID is wriiten out to $ROOTDIR/var/run/named/named.pid before reporting sucess
Comment 2 Martin Stransky 2006-10-05 07:17:48 EDT
applied to rawhide, thanks.

Note You need to log in before you can comment on or make changes to this bug.