Bug 209415 - iscsi-initiator-utils should create and own /var/lib/iscsi and /var/lock/iscsi
iscsi-initiator-utils should create and own /var/lib/iscsi and /var/lock/iscsi
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iscsi-initiator-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Christie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-05 05:59 EDT by Mark McLoughlin
Modified: 2012-06-26 12:09 EDT (History)
1 user (show)

See Also:
Fixed In Version: 6.2.0.695-0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-27 03:03:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2006-10-05 05:59:41 EDT
In order for the initscripts to be able to bindmount a tmpfs over
/var/lib/iscsi, the directory needs to exist.

So, it would be useful if the package created the directories. Also, it's
standard practice for packages to own their directories (e.g so rpm -qf
/var/lib/iscsi works)

suggest:

  - create /var/lib/iscsi/nodes, /var/lib/iscsi/send_targets and /var/lock/iscsi
    in %install

  - add those dirs to the %files list, using the %dir directive

You could probably remove the patches that create those dirs at runtime, then.
Comment 1 Mike Christie 2006-10-05 12:42:11 EDT
Doh, how many times am I going to mess up on these dirs? :)

At least I am learning what the correrct procedure is. We will not be able to
get this into the initial release of FC6 due to the freeze (unless you can tell
Jesse it is critical), but I will check in fixes into cvs in a minute or two here.

Thanks
Comment 2 Mike Christie 2006-10-05 21:35:48 EDT
I fixed this in iscsi-initiator-utils-6_2_0_695-0_6. It is checked in cvs and
built into brew. I so not think they are going to let me update the rpm for the
initial release of FC6, so as soon as we can do a update I will make sure this
gets moved.
Comment 3 Mark McLoughlin 2007-04-27 03:03:16 EDT
Fixed by this:

+* Thu Oct 5 2006 Mike Christie <mchristie@redhat.com> - 6.2.0.695-0.6
+- BZ 209523 make sure the network is not going to get shutdown so
+iscsi devices (include iscsi root and dm/md over iscsi) get syncd.
+- BZ 209415 have package create iscsi var dirs

Note You need to log in before you can comment on or make changes to this bug.