Bug 20943 - ppp-watch exits when pppd dies on error condition
Summary: ppp-watch exits when pppd dies on error condition
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-16 06:53 UTC by j. alan eldridge
Modified: 2014-03-17 02:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-26 05:52:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description j. alan eldridge 2000-11-16 06:53:47 UTC
1. USB ACM modem on /dev/modem ==> /dev/input/ttyACM0.
2. sometimes, when connection is terminated, ACM driver gets into a bizarre
state [see below].
3. due to (2), pppd attempts to reconnect and dies trying to open
/dev/modem [which it should, the modem moved from ttyACM0 to ttyACM1].
4. due to (3) -- i think -- ppp-watch exits.
5. at this point the connection is not coming back up without manual
intervention.

Nov 15 09:27:12 wozzle kernel: usb-uhci-debug.h:    TD Link Terminate
Nov 15 09:27:12 wozzle kernel: usb-uhci-debug.h:   TD @ cf45cb20/0F45CB20,
MaxLe
n=3f DT1 EP=6 Dev=3 PID=( IN  ) buf=06016da0
Nov 15 09:27:12 wozzle pppd[6593]: Hangup (SIGHUP)
Nov 15 09:27:12 wozzle pppd[6593]: Modem hangup
Nov 15 09:27:12 wozzle kernel: usb-uhci-debug.h:     Len=7ff e0 IOC Stalled
CRC/
Timeo 
[lots of this, then ...]
Nov 15 09:27:13 wozzle pppd[6593]: Connection terminated.
Nov 15 09:27:13 wozzle pppd[6593]: Connect time 820.5 minutes.
Nov 15 09:27:13 wozzle pppd[6593]: Sent 2637623 bytes, received 39556031
bytes.Nov 15 09:27:13 wozzle kernel: usb-uhci-debug.h:     Len=7ff e0 IOC
Stalled CRC/
Timeo 
Nov 15 09:27:13 wozzle kernel: usb-uhci-debug.h:    TD Link Terminate
Nov 15 09:27:13 wozzle kernel: usb-uhci-debug.h:   TD @ cf45cae0/0F45CAE0,
MaxLe
n=3f DT1 EP=6 Dev=3 PID=( IN  ) buf=06016da0
[ lots more of this, then... ]
Nov 15 09:27:13 wozzle kernel: usb.c: USB disconnect on device 3
[ more noise ]
Nov 15 09:27:13 wozzle kernel: usb.c: USB new device connect, assigned
device nu
mber 3
Nov 15 09:27:16 wozzle kernel: ttyACM1: USB ACM device
[ whoops! we changed devices! ]
Nov 15 09:27:23 wozzle ifup-ppp: pppd started for ppp0 on /dev/modem at
115200
Nov 15 09:27:23 wozzle pppd[14259]: pppd 2.3.11 started by root, uid 0
Nov 15 09:27:23 wozzle pppd[14259]: Failed to open /dev/modem: Invalid
argument
[ yeah, the device is gone. ]
Nov 15 09:27:23 wozzle pppd[14259]: Exit.
[ and now ppp-watch comes down, too.]

a separate bug will be filed on the usb stuff.


Nov 15 09:27:13 wozzle pppd[6593]: Exit.

Comment 1 Bill Nottingham 2000-11-21 16:06:43 UTC
If the device changes so that the /dev/modem is no longer valid,
how is ppp-watch exiting a problem?



Note You need to log in before you can comment on or make changes to this bug.