Bug 209527 - XENBUS: Device with no driver and powernow-k8: Processor cpuid 681 not supported
XENBUS: Device with no driver and powernow-k8: Processor cpuid 681 not supported
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-05 16:04 EDT by Itamar Reis Peixoto
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-06 22:13:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
domU create error (8.75 KB, text/plain)
2006-10-05 16:04 EDT, Itamar Reis Peixoto
no flags Details
CPU INFO (535 bytes, text/plain)
2006-10-05 16:05 EDT, Itamar Reis Peixoto
no flags Details
xend.log (15.89 KB, application/octet-stream)
2006-10-05 16:06 EDT, Itamar Reis Peixoto
no flags Details

  None (edit)
Description Itamar Reis Peixoto 2006-10-05 16:04:10 EDT
Description of problem:

I have alot of problems with xen,

powernow-k8: Processor cpuid 681 not supported (message in dmesg on dom0 and 
When I try do start domU)

I can't create domU

XENBUS: Device with no driver: device/vbd/2049
XENBUS: Device with no driver: device/vbd/2050
XENBUS: Device with no driver: device/vif/0








Version-Release number of selected component (if applicable):
xen-libs-3.0.2-44
python-xeninst-0.94.0-1
kernel-xen-2.6.18-1.2741.fc6
xen-3.0.2-44


How reproducible:

When domO boot and When I am try to create domU
Comment 1 Itamar Reis Peixoto 2006-10-05 16:04:10 EDT
Created attachment 137847 [details]
domU create error
Comment 2 Itamar Reis Peixoto 2006-10-05 16:05:18 EDT
Created attachment 137848 [details]
CPU INFO 

/proc/cpuinfo
Comment 3 Itamar Reis Peixoto 2006-10-05 16:06:15 EDT
Created attachment 137849 [details]
xend.log

xend.log
Comment 4 Itamar Reis Peixoto 2006-10-05 20:55:02 EDT
I am found a solution to boot domU

the xenblk is now a module.

disk = ['file:/vps/root_fs.ext3,sda1,w','file:/vps/swap.img,sda2,w']

to acess the disk the domU needs the xenblk driver, without this driver the 
domU doesn't boot


then I have created a ramdisk "mkinitrd -v -f --with=ext3 --with=xenblk"

Now I can start my domU's


But another problem

I have a domU with debian running fine, but another domU with fedora 5 with 
some messages on console


4gb seg fixup, process pure-ftpd (pid 3903), cs:ip 73:00e6dee4
printk: 920360 messages suppressed.
4gb seg fixup, process pureauth (pid 3920), cs:ip 73:001cc7d0
Comment 5 Bhavna Sarathy 2006-10-05 22:27:30 EDT
Could you please add details regarding the system you are running on? I'm trying
to determine if this is system specific.   

Brian, how different is the FC Xen dom0, domU from the RHEL5 product?
Comment 6 Bhavna Sarathy 2006-10-05 22:44:00 EDT
In order to repo, we need to have:
1) guest config file
2) hv boot line
3) guest kernel boot parms
Comment 7 Bhavna Sarathy 2006-10-05 22:48:03 EDT
Also, why are you running 3.0.2?  It's really old, and we won't be trying to
repo any issue from 3.0.2.  Please try with the latest 3.0.3-testing and let me
know if the issues persist.  The list from comment #6 holds.
Comment 8 Itamar Reis Peixoto 2006-10-05 22:52:11 EDT
I belive RHEL uses a xen0/xenU kernel, FC6test3 have only a unified -xen kernel.

I belive Riel know a solution for this problem

http://people.redhat.com/~riel/RHEL4-Xen-HOWTO

what's the address to download xen 3.0.3 ? there are rpms ?





Comment 9 Itamar Reis Peixoto 2006-10-06 00:37:11 EDT
another issue.

I have only 2 gb of memory on this machine

[root@vpshost ~]# xm mem-set 0 4090000
[root@vpshost ~]# xm list
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0  4090000     1 r-----  16497.3
astisp                                    79      256     1 -b----     48.0
onhost                                    80      512     1 -b----   1670.9
tiago                                     82      128     1 ------   9847.6
[root@vpshost ~]#
Comment 10 Stephen Tweedie 2006-10-06 05:30:50 EDT
Correction --- xen-3.0.3 has NOT been released.  Our xen-3.0.2-44 package *IS*
from xen-3.0.3-testing.  It will be renamed to xen-3.0.3-something once
xen-3.0.3 has actually been released upstream.  3.0.2-44 is fully uptodate.
Comment 11 Stephen Tweedie 2006-10-06 05:40:36 EDT
*Please* do not log huge numbers of issues into a single bugzilla!  This is not
a support mechanism --- it's a bug-tracking mechanism.  The design of bugzilla
is supposed to enable us to track the status of bugs, through reproduction,
testing, committing and release; and we simply cannot do that with multiple bugs
in a single bugzilla, as it is impossible to set the state for each bug separately.

The memory ballooning reporting does look broken; please open that in a separate
bug.

The block frontend driver needs to be loaded in the initrd, yes: our current
release sets this up automatically, so you must be using an upgraded older
release.  You need to add

alias scsi_hostadapter xenblk

to /etc/modprobe.conf to get mkinitrd to automatically load xenblk.

The "4g fixup" messages are informative messages telling you that certain
processes are running in a way that hurts performance somewhat under Xen; they
are almost certainly running against an old library that needs relinked against
a current glibc with "nosegneg" support.

XENBUS: Device with no driver: device/vbd/2049
XENBUS: Device with no driver: device/vbd/2050
XENBUS: Device with no driver: device/vif/0

is reported early in boot, but is hidden by the default kernel "quiet" option;
it is expected because we load vbd and vif drivers as modules, so those devices
will get their drivers attached later on during boot.

Which leaves us with the cpuid message.
Comment 12 Stephen Tweedie 2006-10-06 05:41:52 EDT
Does the cpuid message appear on non-xen kernels too?
Comment 13 Mark Langsdorf 2006-10-06 11:22:58 EDT
The cpuid message is an artifact of the powernow-k8 driver not supporting that
processor variant.  It's harmless - the driver recognized an AMD part, but
probably K7 instead of a K8 - but I'll write a patch to get rid of it.
Comment 14 Itamar Reis Peixoto 2006-10-06 23:54:01 EDT
Does the cpuid message appear on non-xen kernels too?

on normal kernel this message don't appear
Comment 15 Matthew Miller 2007-04-06 14:35:30 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 16 Itamar Reis Peixoto 2007-04-06 20:56:30 EDT
I am using fc6 and lasted xen packages, and now is running fine.

I am also using a initrd with xenblk.


you can close this ticket.

Note You need to log in before you can comment on or make changes to this bug.