Bug 20954 - gcc 2.96 cannot generate ATLAS
gcc 2.96 cannot generate ATLAS
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-16 09:57 EST by Winfrid Tschiedel
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-16 11:21:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of errorous ATLAS generation using gcc 2.96 on Redhat 7.0 (21.40 KB, text/plain)
2000-11-16 10:01 EST, Winfrid Tschiedel
no flags Details

  None (edit)
Description Winfrid Tschiedel 2000-11-16 09:57:17 EST
ATLAS 3.0 generation does not work with gcc 2.96

Part of the ATLAS installation log :

/usr/bin/gcc  -DL2SIZE=262144 -I/tmp/ATLAS/include
-I/tmp/ATLAS/include/Linux_PII -DAdd__ -DStringSunStyle
-fomit-frame-pointer -O -c dmm.c
/usr/bin/gcc  -DL2SIZE=262144 -I/tmp/ATLAS/include
-I/tmp/ATLAS/include/Linux_PII -DAdd__ -DStringSunStyle
-fomit-frame-pointer -O3 -funroll-all-loops -o xdfc d
fc.o dmm.o \
                                   
/tmp/ATLAS/tune/sysinfo/Linux_PII/time.o
/tmp/ATLAS/bin/Linux_PII/ATLrun.sh /tmp/ATLAS/tune/blas/gemm/Linux_PII xdfc 
dNB=40, ldc=40, mu=2, nu=1, ku=40, lat=5: time=0.680000, mflop=436.517647
dNB=40, ldc=40, mu=2, nu=1, ku=40, lat=5: time=0.680000, mflop=436.517647
dNB=40, ldc=40, mu=2, nu=1, ku=40, lat=5: time=0.690000, mflop=430.191304
make[4]: Leaving directory `/tmp/ATLAS/tune/blas/gemm/Linux_PII'
make[3]: *** [RunMMDef] Segmentation fault (core dumped)
make[3]: Leaving directory `/tmp/ATLAS/tune/blas/gemm/Linux_PII'
make[2]: *** [IRunMMDef] Error 2
make[2]: Leaving directory `/tmp/ATLAS/bin/Linux_PII'

Please see answer of ATLAS people :

From rwhaley@cs.utk.edu  Tue Nov 14 17:36:28 2000
Received: from enterprise.cs.utk.edu (ENTERPRISE.CS.UTK.EDU
[128.169.93.19])
        by raptor.hpc.siemens.de (8.9.3/8.9.3) with ESMTP id RAA18060
        for <Winfrid.Tschiedel@hpc.fujitsu-siemens.com>; Tue, 14 Nov 2000
17:36:
26 +0100 (MET)
Received: (from rwhaley@localhost)
        by enterprise.cs.utk.edu (cf v3.2) id LAA16308;
        Tue, 14 Nov 2000 11:18:01 -0500 (EST)
Date: Tue, 14 Nov 2000 11:18:01 -0500 (EST)
From: R Clint Whaley <rwhaley@cs.utk.edu>
Message-Id: <200011141618.LAA16308@enterprise.cs.utk.edu>
To: Winfrid.Tschiedel@hpc.fujitsu-siemens.com
Subject: Re: Error generating ATLAS with gcc 2.96 under Redhat 7.0
Cc: atlas@cs.utk.edu
Status: OR

Winfrid,

>Do you have any experience installing ATLAS with gcc 2.96
>under Redhat 7.0. The generation dies with a core dump.
>Please see attached log. 
>If you need further documents, please do not hesitate to ask.

There appears to be at least one compiler error in 2.96 which prevents
ATLAS from installing.  We've had roughly 5-8 messages reporting various
errors using 2.96, and the only fix seems to be to use a different version
of gcc.  Since the gcc compiler people have officially announced that 2.96
is an unsupported gcc release, not intended for the average user, this
seems
like a reasonable solution . . .

Cheers,
Clint
-- 
_______________________________________________________________________________

Fujitsu Siemens Computers
OEA VC HPC                   Email:
winfrid.tschiedel@hpc.fujitsu-siemens.com
Otto-Hahn-Ring 6             Tel. : ++49-89-636-45652
81739 Muenchen               Fax  : ++49-89-636-44088 

MS Exchange : winfrid.tschiedel@fujitsu-siemens.com
Comment 1 Winfrid Tschiedel 2000-11-16 10:01:30 EST
Created attachment 5441 [details]
Log of errorous ATLAS generation using gcc 2.96 on Redhat 7.0
Comment 2 Jakub Jelinek 2000-11-16 11:21:29 EST
I believe this should be fixed by http://gcc.gnu.org/ml/gcc-patches/2000-11/msg00583.html
which will be in gcc-2.96-64, at least with that gcc it no longer crashed,
with 2.96-63 I got crashes.

Note You need to log in before you can comment on or make changes to this bug.