Bug 209565 - gmime build dependency should be raised to glib2-devel >= 2.6
gmime build dependency should be raised to glib2-devel >= 2.6
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gmime (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-05 21:28 EDT by Bernard Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-12 12:19:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernard Johnson 2006-10-05 21:28:26 EDT
Description of problem:
gmime build requirement is for glib2-devel >= 2.0.0.  The g_mkdir was introduced
in 2.6, so the build dependency should be set to >= 2.6

Version-Release number of selected component (if applicable):
gmime-2.2.3-3

How reproducible:
Always

Steps to Reproduce:
1. Attempt rebuild with glib2 < 2.6
2.
3.
  
Actual results:
Link failure with g_mkdir

Expected results:
Successful compile

Additional info:
Comment 1 Alexander Larsson 2006-10-12 12:19:49 EDT
I commited the fix to cvs, it'll be in the next rebuild.

Note You need to log in before you can comment on or make changes to this bug.