Bug 209595 - gjdoc should require antlr
gjdoc should require antlr
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gjdoc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
: 209513 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-06 05:36 EDT by Stepan Kasal
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-10 05:15:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stepan Kasal 2006-10-06 05:36:00 EDT
My build of libgtk-java failed with this error:

java.lang.reflect.InvocationTargetException
   at java.lang.reflect.Method.invoke(libgcj.so.7rh)
   at
gnu.classpath.tools.gjdoc.Main.startDoclet(gnu-classpath-tools-gjdoc-0.7.7.jar.so)
   at gnu.classpath.tools.gjdoc.Main.start(gnu-classpath-tools-gjdoc-0.7.7.jar.so)
   at gnu.classpath.tools.gjdoc.Main.main(gnu-classpath-tools-gjdoc-0.7.7.jar.so)
Caused by: java.lang.NoClassDefFoundError: gnu.classpath.tools.gjdoc.expr.Evaluator
   at java.lang.Class.initializeClass(libgcj.so.7rh)
   at
gnu.classpath.tools.gjdoc.FieldDocImpl.constantValue(gnu-classpath-tools-gjdoc-0.7.7.jar.so)
   at
gnu.classpath.tools.gjdoc.FieldDocImpl.constantValue(gnu-classpath-tools-gjdoc-0.7.7.jar.so)
   at
gnu.classpath.tools.doclets.htmldoclet.HtmlDoclet.printMemberDetails(gnu-classpath-tools-gjdoc-0.7.7.jar.so)
   at
gnu.classpath.tools.doclets.htmldoclet.HtmlDoclet.printClassPage(gnu-classpath-tools-gjdoc-0.7.7.jar.so)
   at
gnu.classpath.tools.doclets.htmldoclet.HtmlDoclet.run(gnu-classpath-tools-gjdoc-0.7.7.jar.so)
   at
gnu.classpath.tools.doclets.AbstractDoclet.startInstance(gnu-classpath-tools-gjdoc-0.7.7.jar.so)
   at
gnu.classpath.tools.doclets.AbstractDoclet.start(gnu-classpath-tools-gjdoc-0.7.7.jar.so)
   at java.lang.reflect.Method.invoke(libgcj.so.7rh)
   ...3 more
Caused by: java.lang.ClassNotFoundException: antlr.CharScanner not found in
gnu.gcj.runtime.SystemClassLoader{urls=[file:/usr/share/java/com-sun   at
java.net.URLClassLoader.findClass(libgcj.so.7rh)
   at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.7rh)
   at java.lang.ClassLoader.loadClass(libgcj.so.7rh)
   at java.lang.ClassLoader.loadClass(libgcj.so.7rh)
   at java.lang.VMClassLoader.defineClass(libgcj.so.7rh)
   at java.lang.ClassLoader.defineClass(libgcj.so.7rh)
   at java.security.SecureClassLoader.defineClass(libgcj.so.7rh)
   at java.net.URLClassLoader.findClass(libgcj.so.7rh)
   at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.7rh)
   at java.lang.ClassLoader.loadClass(libgcj.so.7rh)
   at java.lang.ClassLoader.loadClass(libgcj.so.7rh)
   at java.lang.Class.initializeClass(libgcj.so.7rh)
   ...11 more

adding BuildRequires: antlr works around the issue.

I guess gjdoc should require antlr.
Comment 1 Tom Tromey 2006-10-06 10:56:46 EDT
CCing Andrew Overholt.  He checked in a fix for this, but I'm not
sure of the status of the package.
Comment 2 Andrew Overholt 2006-10-06 13:26:36 EDT
This is fixed and should be in rawhide tomorrow.  Sorry about this.

Please close when it is fixed for you.
Comment 3 Andrew Overholt 2006-10-06 14:49:44 EDT
*** Bug 209513 has been marked as a duplicate of this bug. ***
Comment 4 Stepan Kasal 2006-10-10 05:15:04 EDT
The bug is fixed, indeed.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.