Bug 209656 - java error eclipse 3.1.2 will not start classloader unknown source
java error eclipse 3.1.2 will not start classloader unknown source
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-06 13:45 EDT by Ian Shields
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-06 14:32:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Shields 2006-10-06 13:45:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.7) Gecko/20060913 Fedora/1.5.0.7-1.fc5 Firefox/1.5.0.7 pango-text

Description of problem:
Attempting to run eclipse on FC5 on an AMD 64 system results in popup with following text.

An error has occurred. See the log file
/home/ian/workspace/.metadata/.log.

The log is fairly short.
!SESSION 2006-10-06 13:09:58.936 -----------------------------------------------
eclipse.buildId=M20060118-1600
java.version=1.5.0_06
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.osgi 2006-10-06 13:10:01.512
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: /home/ian/.eclipse/org.eclipse.platform_3.1.2/configuration/org.eclipse.osgi/bundles/68/1/.cp/libswt-pi-gtk-3139.so: /home/ian/.eclipse/org.eclipse.platform_3.1.2/configuration/org.eclipse.osgi/bundles/68/1/.cp/libswt-pi-gtk-3139.so: wrong ELF class: ELFCLASS64
	at java.lang.ClassLoader$NativeLibrary.load(Native Method)
	at java.lang.ClassLoader.loadLibrary0(Unknown Source)
	at java.lang.ClassLoader.loadLibrary(Unknown Source)
	at java.lang.Runtime.loadLibrary0(Unknown Source)
	at java.lang.System.loadLibrary(Unknown Source)
	at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
	at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:19)
	at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
	at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
	at org.eclipse.swt.widgets.Display.<clinit>(Display.java:122)
	at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:381)
	at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:155)
	at org.eclipse.ui.internal.ide.IDEApplication.createDisplay(IDEApplication.java:128)
	at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:79)
	at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
	at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
	at org.eclipse.core.launcher.Main.run(Main.java:973)
	at org.eclipse.core.launcher.Main.main(Main.java:948)

Eclipse has not previously been installed on this system.
$ java -version
java version "1.5.0_06"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
Java HotSpot(TM) Client VM (build 1.5.0_06-b05, mixed mode, sharing)




Version-Release number of selected component (if applicable):
eclipse-platform-3.1.2-1jpp_15fc.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Attempt to launch eclipse from Gnome panel (Applications->Programming->Eclipse)
2.
3.

Actual Results:
Popup and error log as described above.

Expected Results:
Eclipse should have launched

Additional info:
Comment 1 Andrew Overholt 2006-10-06 13:52:33 EDT
I'm assuming you picked ia64 in the arch list by accident?  Looking at your
comments, it looks like your running on x86_64 so I've changed the arch to that.

While we don't support running with the Sun VM, I'm willing to bet you're
running the 32-bit Sun VM on an x86_64 system.  yum will install the 64-bit SWT
binaries on an x86_64 system (unless you specify .i386) and these won't work
with a 32-bit JVM.  Is this your situation?
Comment 2 Ian Shields 2006-10-06 14:13:47 EDT
Correct. IA64 was a mental lapse. x86_64 is correct. You're also correct about
the Sun JRE. Not sure when or why I installed it, but it was the 32-bit version
(jre-1.5.0_06-fcs). Uninstalling that seems to have solved the problem.

If there's any way to figure out whether you're trying to run a 64-bit SWT with
a 32-bit JVM, it woudl be a nice check to add rather than the output I got which
is very cryptic.

Thanks for the help.

Ian.
Comment 3 Andrew Overholt 2006-10-06 14:32:41 EDT
(In reply to comment #2)
> If there's any way to figure out whether you're trying to run a 64-bit SWT with
> a 32-bit JVM, it woudl be a nice check to add rather than the output I got which
> is very cryptic.

Yeah, this is a common pitfall.  So common, in fact, that it's in the release
notes.  There's not much we can do about Sun's error reporting, though :)  You
could file a bug with them, I guess :)

> Thanks for the help.

No problem.

Andrew
Comment 4 Ian Shields 2006-10-06 18:46:40 EDT
Maybe it woudl help if the 64bit eclipse start edjava with the -d64 option and
gij  supported the parameter. 

Ian.
Comment 5 Andrew Overholt 2006-10-06 21:49:32 EDT
(In reply to comment #4)
> Maybe it woudl help if the 64bit eclipse start edjava with the -d64 option and
> gij  supported the parameter. 

/usr/bin/eclipse is a binary wrapper written in C that launches the VM.  Eclipse
3.3, however, is supposed to include a binary wrapper written using libjvm so
it'll get better then.

Note You need to log in before you can comment on or make changes to this bug.