Bug 20978 - EXT2-fs error (device sd(8,4)) Free blocks count corrupted
EXT2-fs error (device sd(8,4)) Free blocks count corrupted
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: raidtools (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-16 15:29 EST by adler
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-05 06:29:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adler 2000-11-16 15:29:49 EST
I've created a 280Gigabyte file system over 4
70 Gig partitions using a raid0 file system.
When I started using the file system, I started
getting the following errors in my /var/log/messages
file.


Nov 14 17:02:31 phyalpha0 kernel: EXT2-fs error (device md(9,0)):
ext2_new_block: Free blocks count corrupted for block group 1838 
Nov 14 17:03:34 phyalpha0 kernel: EXT2-fs error (device md(9,0)):
ext2_new_block: Free blocks count corrupted for block group 1838 
Nov 14 17:04:36 phyalpha0 kernel: EXT2-fs error (device md(9,0)):
ext2_new_block: Free blocks count corrupted for block group 1838 
Nov 14 17:05:40 phyalpha0 kernel: EXT2-fs error (device md(9,0)):
ext2_new_block: Free blocks count corrupted for block group 1838 
Nov 14 17:06:44 phyalpha0 kernel: EXT2-fs error (device md(9,0)):
ext2_new_block: Free blocks count corrupted for block group 1838 
Nov 16 09:43:24 phyalpha0 kernel: EXT2-fs error (device sd(8,4)):
ext2_check_blocks_bitmap: Wrong free blocks count for group 20, stored = 1,
counted = 0 
Nov 16 09:43:24 phyalpha0 kernel: EXT2-fs error (device sd(8,4)):
ext2_check_blocks_bitmap: Wrong free blocks count for group 21, stored = 2,
counted = 0 
Nov 16 09:43:24 phyalpha0 kernel: EXT2-fs error (device sd(8,4)):
ext2_check_blocks_bitmap: Wrong free blocks count in super block, stored =
1323615, counted = 1323612 
Nov 16 15:11:14 dmz0 kernel: EXT2-fs error (device md(9,0)):
ext2_new_block: Free blocks count corrupted for block group 1122 

I'm worried that the file system is not working properly. I'll
be glad to run any tests you wish to further constrain the
problem.
Comment 1 Arjan van de Ven 2001-06-05 05:44:27 EDT
Does this still show on 2.2.19 kernels ?
Comment 2 adler 2001-06-05 06:28:57 EDT
Sorry, your too late for this. Because of this bug, I swapped out
the alpha mother board for an intel one, and I'm now running SGI's
redhat 7.1 with xfs. the 280Gig file system is an XFS one and
seems to be running fine. I guess you should close this one since
I will not be able to reproduce errors for you.

Note You need to log in before you can comment on or make changes to this bug.