Bug 20979 - 'package LC_MESSAGES not found in file index' after source rebuild
'package LC_MESSAGES not found in file index' after source rebuild
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-16 15:52 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-21 14:10:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-16 15:52:19 EST
I pulled the glibc-2.1.3-15.src.rpm from the redhat 6.2 CD. After I 
installed the package I added one of my own patches to the SOURCES 
directory and added the patch to my glibc.spec file (in the top section 
and in the prep section) in the SPECS directory. I also changed the 
release from 15 to 15b After that I rebuild the package with an rpm -ba 
glibc.spec in the SPECS directory.
When I tried to upgrade the installed version of glibc with my version of 
glibc by typing rpm -U glibc-2.1.3-15b.i386.rpm I got 26 times: 'package 
LC_MESSAGES not found in file index'.
When I removed the current installed version with a rpm -e glibc --nodeps 
(I know this was dangarous, and most of my software didn't work anymore, 
but my bash still did), and installed my version of glibc: rpm -ivh glibc-
2.1.3-15b.i386.rpm it installed just fine.
Maybe a bug in the glibc.spec file?
Comment 1 Jakub Jelinek 2000-11-17 05:16:41 EST
This used to be a rpm bug which has been fixed in later rpm releases I think.
Comment 2 Need Real Name 2000-11-21 14:10:46 EST
I recompiled the stuff after I installed the package enhancement for RH 6.2 
(version 3.0.5-9.6x) and the problem seems to be gone away.

Note You need to log in before you can comment on or make changes to this bug.