This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 209797 - gulm init script will hang if a master is never found.
gulm init script will hang if a master is never found.
Status: CLOSED WORKSFORME
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gulm (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-06 16:50 EDT by Corey Marthaler
Modified: 2009-04-16 16:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 19:01:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2006-10-06 16:50:08 EDT
Description of problem:
I had one machine in a cluster come up with the gulm init script on and a valid
cluster.conf file, and it ended up hanging because I never started gulm on any
of the other nodes in the cluster.

Starting ccsd: [  OK  ]
Starting cman:[WARNING]
[WARNING]lustered mirror log:[WARNING]
Starting lock_gulmd:                
[HANG]

It appears that if a master is never found then it will hang. We need to have it
timeout eventually continue booting the node.
wait_for_master()
{
        i=0
        rtrn=0
        stoptime=$(($SECONDS + $GULM_QUORUM_TIMEOUT))
        while [ $GULM_QUORUM_TIMEOUT -eq 0 -o $SECONDS -lt $stoptime ]
        do
                find_master
                rtrn=$?
                case $rtrn in
                0) break ;; # master was found
                1) ;;       # master was not found
                2) break ;; # gulm_tool error
                3) break ;; # we are expired
                esac

                sleep 5
                i=$(($i+1))
        done

        return $rtrn
}
 

Version-Release number of selected component (if applicable):
[root@link-08 ~]# rpm -q gulm
gulm-1.0.7-0
Comment 1 Chris Feist 2006-10-18 18:59:21 EDT
I've been unable to replicate this with Corey, moving to NEEDINFO until we see
this again.
Comment 2 Corey Marthaler 2006-11-21 19:01:28 EST
Have not been able to reproduce this, will reopen if seen again.

Note You need to log in before you can comment on or make changes to this bug.