Bug 209864 - New 0.5.2 libtunepimp breaks upgrade
New 0.5.2 libtunepimp breaks upgrade
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kid3 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-06 22:56 EDT by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-07 21:09:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2006-10-06 22:56:05 EDT
Description of problem:
Some apps still depend on 0.4.3 version of libtunepimp

Version-Release number of selected component (if applicable):
libtunepimp-0.5.2-1.fc5

How reproducible:
Always

Steps to Reproduce:
1. sudo yum upgrade


Actual results:
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package emacs-ess.noarch 0:5.3.3-1.tgm set to be updated
---> Package acpitool.i386 0:0.4.6-2.fc5 set to be updated
---> Package kernel-devel.i686 0:2.6.17-1.2187_FC5 set to be installed
---> Package kernel-suspend2.i686 0:2.6.17-1.2187_1.fc5.cubbi_suspend2 set to be
installed
---> Package kernel-suspend2-devel.i686 0:2.6.17-1.2187_1.fc5.cubbi_suspend2 set
to be updated
---> Package kernel.i686 0:2.6.17-1.2187_FC5 set to be installed
---> Package libtunepimp-devel.i386 0:0.5.2-1.fc5 set to be updated
---> Package libtunepimp.i386 0:0.5.2-1.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libtunepimp.so.3 for package: amarok
--> Processing Dependency: libtunepimp = 0.4.3 for package:
libtunepimp-extras-nonfree
--> Processing Dependency: libtunepimp.so.3 for package: kid3
--> Processing Dependency: libofa.so.0 for package: libtunepimp
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libofa.i386 0:0.9.3-8.fc5 set to be updated
--> Running transaction check
--> Processing Dependency: libtunepimp.so.3 for package: amarok
--> Processing Dependency: libtunepimp = 0.4.3 for package:
libtunepimp-extras-nonfree
--> Processing Dependency: libtunepimp.so.3 for package: kid3
--> Finished Dependency Resolution
Error: Missing Dependency: libtunepimp.so.3 is needed by package amarok
Error: Missing Dependency: libtunepimp = 0.4.3 is needed by package
libtunepimp-extras-nonfree
Error: Missing Dependency: libtunepimp.so.3 is needed by package kid3


Expected results:
Upgrade would work

Additional info:
Is there a compatibility package to be introduced?  Or are the other packages in
the process of also being rebuilt?  I checked
http://buildsys.fedoraproject.org/build-status/success.psp but I didn't see if
kid3 or amarok were being rebuilt against the new libtunepimp.
Comment 1 Alex Lancaster 2006-10-06 22:57:19 EDT
Fixed summary.
Comment 2 Rex Dieter 2006-10-07 08:13:46 EDT
AFAIK, amarok was fixed this morning:
http://buildsys.fedoraproject.org/build-status/job.psp?email=rdieter@math.unl.edu&uid=19245

kid3 is still pending, reassigning there.
Comment 3 Rex Dieter 2006-10-07 08:14:32 EDT
Ville, I can fix things up, and push a rebuild if you're busy.
Comment 4 Alex Lancaster 2006-10-07 19:05:59 EDT
I thought it was part of the automated build system that should prevent a
package being pushed if it would break other dependent packages.  I'm surprised
that this isn't automated yet and because of yum's "all-or-nothing" upgrade
policy it has the potential to block important security updates until the
dependent package is fixed.
Comment 5 Rex Dieter 2006-10-07 21:09:01 EDT
Would be nice, but no.

%changelog      
* Sat Oct 07 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7-2
- Disable musicbrainz support by default, not ready for tunepimp 0.5 yet.

Ville, pushed fixed build, tried to simply sync to devel/ branch, but the
%bcond_with tunepimp
construct seemed to bork my attempt to 'make tag', so I did
%define with_tunepimp 0
and s/with tunepimp/with_tunepimp/
instead.
Comment 6 Ville Skyttä 2006-10-08 14:37:28 EDT
%bcond_* needs rpm >= 4.4.  Thanks for taking care of kid3 while I was 
offline.

However I think soname bumps in released distro versions require considerably 
more communication than "leaning towards doing it in FC5 later depending how 
well it goes in devel" maybe-announcement and then three weeks later almost 
out of the blue it hits the FC5 repo giving fellow contributors practically no 
time to react between the note on -maintainers and the matter of fact.

In the kid3 case, there was nothing I could have done - I was offline as 
mentioned on FESCO list.  The new offending libtunepimp was also submitted on 
Friday, immediately before a weekend is a bad idea in the first place unless 
you've made sure that maintainers of all dependent packages are available to 
take care of it or have arranged so that someone else can do that quickly.  
Signers are another group whose availability needs to be ensured.

Announcing the intent that you're going to actually go ahead and do the 
incompatible upgrade in FC-5 and waiting a week instead of a few hours would 
have been better.

Note You need to log in before you can comment on or make changes to this bug.