Bug 209883 - bcm43xx tx timeout and lockup
bcm43xx tx timeout and lockup
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-07 08:33 EDT by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-13 10:09:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2006-10-07 08:33:27 EDT
Oct  7 06:38:30 shinybook kernel: SoftMAC: Scanning 14 channels
Oct  7 06:38:30 shinybook kernel: SoftMAC: Scanning finished
Oct  7 06:40:31 shinybook kernel: SoftMAC: Start scanning with channel: 1
Oct  7 06:40:31 shinybook kernel: SoftMAC: Scanning 14 channels
Oct  7 06:40:31 shinybook kernel: SoftMAC: Scanning finished
Oct  7 06:42:31 shinybook kernel: SoftMAC: Start scanning with channel: 1
Oct  7 06:42:31 shinybook kernel: SoftMAC: Scanning 14 channels
Oct  7 06:42:31 shinybook kernel: NETDEV WATCHDOG: eth1: transmit timed out
Oct  7 06:42:31 shinybook kernel: bcm43xx: Controller RESET (TX timeout) ...
Oct  7 06:42:31 shinybook kernel: bcm43xx: Chip ID 0x4306, rev 0x2
Oct  7 06:42:31 shinybook kernel: bcm43xx: Number of cores: 6
Oct  7 06:42:31 shinybook kernel: bcm43xx: Core 0: ID 0x800, rev 0x2, vendor
0x4243, enabled
Oct  7 06:42:31 shinybook kernel: bcm43xx: Core 1: ID 0x812, rev 0x4, vendor
0x4243, enabled
Oct  7 06:42:31 shinybook kernel: bcm43xx: Core 2: ID 0x80d, rev 0x1, vendor
0x4243, enabled
Oct  7 06:42:31 shinybook kernel: bcm43xx: Core 3: ID 0x807, rev 0x1, vendor
0x4243, disabled
Oct  7 06:42:31 shinybook kernel: bcm43xx: Core 4: ID 0x804, rev 0x7, vendor
0x4243, enabled
Oct  7 06:42:31 shinybook kernel: bcm43xx: Core 5: ID 0x812, rev 0x4, vendor
0x4243, disabled
Oct  7 06:42:31 shinybook kernel: bcm43xx: Ignoring additional 802.11 core.
Oct  7 06:42:31 shinybook kernel: bcm43xx: PHY connected
Oct  7 06:42:31 shinybook kernel: bcm43xx: Detected PHY: Version: 1, Type 2,
Revision 1
Oct  7 06:42:31 shinybook kernel: bcm43xx: Detected Radio: ID: 2205017f (Manuf:
17f Ver: 2050 Rev: 2)
Oct  7 06:42:31 shinybook kernel: bcm43xx: Radio turned off
Oct  7 06:42:31 shinybook kernel: bcm43xx: Radio turned off
Oct  7 06:42:31 shinybook kernel: bcm43xx: Controller restarted
Oct  7 06:42:31 shinybook kernel: SoftMAC: Scanning finished
Oct  7 09:54:18 shinybook syslogd 1.4.1: restart.
Oct  7 09:54:18 shinybook kernel: klogd 1.4.1, log source = /proc/kmsg started.
Oct  7 09:54:18 shinybook kernel: Using PowerMac machine description
Oct  7 09:54:18 shinybook kernel: Total memory = 1024MB; using 2048kB for hash
table (at cfe00000)
Oct  7 09:54:18 shinybook kernel: Linux version 2.6.18-1.2741.fc6
(brewbuilder@js20-bc2-12.build.redhat.com) (gcc version
 4.1.1 20060928 (Red Hat 4.1.1-28)) #1 Wed Oct 4 20:18:10 EDT 2006
Comment 1 John W. Linville 2006-10-12 10:07:26 EDT
David, did the interface "work" afterwards?  Or was it borked thereafter?
Comment 2 David Woodhouse 2006-10-12 10:19:48 EDT
Er, after the machine crashed and I power cycled it? It was fine after that...
till the next time :)
Comment 3 James 2006-10-20 17:27:30 EDT
I believe I've just run into this (kernel-2.6.18-1.2200.fc5). The notebook had
been fine all day (and long before that, with the previous kernel). However, I
have noticed on two occasions the wireless connection simply "collapsed" hand
had to be restarted with NetworkManager.

About an hour ago I left it for half an hour (it'd been on all day as well), and
when I came back it'd locked solid (CPU seemed to be in a spin). The last
message in the logs was

Oct 20 21:25:52 localhost kernel: NETDEV WATCHDOG: dev1804289383: transmit timed out
Oct 20 21:25:52 localhost kernel: bcm43xx: Controller RESET (TX timeout) ...
Oct 20 21:25:52 localhost kernel: bcm43xx: select_wireless_core: cleanup
Oct 20 21:26:02 localhost kernel: NETDEV WATCHDOG: dev1804289383: transmit timed out
Oct 20 21:26:02 localhost kernel: bcm43xx: Controller RESET (TX timeout) ...
Oct 20 22:08:38 localhost syslogd 1.4.1: restart.
Oct 20 22:08:38 localhost kernel: klogd 1.4.1, log source = /proc/kmsg started.
Oct 20 22:08:38 localhost kernel: Linux version 2.6.18-1.2200.fc5
(brewbuilder@hs20-bc2-3.build.redhat.com) (gcc version 4.1.1 20060525 (Red Hat
4.1.1-1)) #1 Sat Oct 14 16:59:26 EDT 2006

Comment 4 John W. Linville 2006-10-21 10:04:47 EDT
jhe, please try the test kernels here:

   http://people.redhat.com/linville/kernels/fc5/

Do those have the same issue?
Comment 5 John W. Linville 2007-02-13 10:09:07 EST
Closed due to lack of response.  Please reopen when requested information 
becomes available...thanks!

Note You need to log in before you can comment on or make changes to this bug.