This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 209886 - An extra dir appears in the system root / after last updates
An extra dir appears in the system root / after last updates
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-07 10:09 EDT by Dmitry Butskoy
Modified: 2013-07-02 19:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-10 08:08:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dmitry Butskoy 2006-10-07 10:09:15 EDT
After the updating of tetex packages an extra directory has appeared in the
system root:
"/.texmf-var".
(This directory contains only an empty subdir web2c and a file ls-R).

At least both tetex-3.0-20.FC5 and tetex-3.0-29.fc5 are affected.

It seems that update/install process expects the invoking under a user, and
tries to write the ~/.texmf-var to the homedir of the user. The actual install
knows nothing about "a user", or just has the empty HOME environment. And
"private-user-config" subdir appears at the system root "/" ...
Comment 1 Jindrich Novy 2006-10-09 07:38:14 EDT
Weird, I cannot see it while installing tetex-3.0-29.fc5 to a pristine chroot.
I'll try to install tetex-3.0-20.FC5 and to upgrade to tetex-3.0-29.fc5 to see
what happens.
Comment 2 Dmitry Butskoy 2006-10-09 07:48:42 EDT
It seems that it happened at some previous updates of tetex.
When I remove this dir before the updating to the latest tetex, it not appears
after the update.


IMHO if you cannot reproduce this issue, just let foo on it... :)
Comment 3 Jindrich Novy 2006-10-10 08:08:49 EDT
Ok, I tested the update from tetex-3.0-20.FC5 to tetex-3.0-29.fc5 and saw no
/.texmf-var in root of the chroot -> closing NOTABUG, feel free to open another
bug when some other breakage occurs though ;-)

Note You need to log in before you can comment on or make changes to this bug.