Bug 209888 - connecting with simple method fails
connecting with simple method fails
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Tim Niemueller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-07 10:35 EDT by Thilo Pfennig
Modified: 2008-01-19 05:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-19 05:18:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thilo Pfennig 2006-10-07 10:35:35 EDT
Description of problem:

I can not connect via a simple shared key method

Version-Release number of selected component (if applicable):
0.3.2-7.fc5

How reproducible:

always

Steps to Reproduce:
1. configure simple static host to host network like it is described here:
http://openvpn.net/static.html

If I export the configuration it looks like this:
[openvpn]
description=Sk28 Netzwerk
connection-type=shared-key
remote=192.168.200.98
dev=tun
proto=udp
ca=
cert=
key=
comp-lzo=no
shared-key=/home/vinci/.openvpn/static.key
local-ip=10.8.0.2
remote-ip=10.8.0.1
username=
cipher=(null)
ta=(null)
ta_dir=(null)
routes=

  
Actual results:

/var/log/messages
"""
Oct  7 16:16:48 stevie openvpn[6317]: TUN/TAP read bytes,0
Oct  7 16:16:48 stevie openvpn[6317]: TUN/TAP write bytes,0
Oct  7 16:16:48 stevie openvpn[6317]: TCP/UDP read bytes,0
Oct  7 16:16:48 stevie openvpn[6317]: TCP/UDP write bytes,0
Oct  7 16:16:48 stevie openvpn[6317]: Auth read bytes,0
Oct  7 16:16:48 stevie openvpn[6317]: END
Oct  7 16:16:57 stevie openvpn[6317]: Peer Connection Initiated with
192.168.200.98:1194
Oct  7 16:16:59 stevie openvpn[6317]: Initialization Sequence Completed
Oct  7 16:30:55 stevie NetworkManager: <information>    Will activate VPN
connection 'Sk28 Netzwerk', service 'org.freedesktop.NetworkManager.openvpn',
user_name 'vinci', vpn_data 'connection-type / shared-key / dev / tun / remote /
192.168.200.98 / proto / udp / ca /  / cert /  / key /
/home/vinci/.openvpn/static.key / comp-lzo / no / shared-key /
/home/vinci/.openvpn/static.key / local-ip / 10.8.0.2 / remote-ip / 10.8.0.1 /
username / ', route '10.0.0.0/24'.
Oct  7 16:30:55 stevie NetworkManager: <information>    VPN Activation (Sk28
Netzwerk) Stage 1 of 4 (Connection Prepare) scheduled...
Oct  7 16:30:55 stevie NetworkManager: <information>    VPN Activation (Sk28
Netzwerk) Stage 1 of 4 (Connection Prepare) ran VPN service daemon
org.freedesktop.NetworkManager.openvpn (PID 6655)
Oct  7 16:30:55 stevie NetworkManager: <information>    VPN Activation (Sk28
Netzwerk) Stage 1 of 4 (Connection Prepare) complete.
Oct  7 16:30:55 stevie NetworkManager: <information>    VPN Activation (Sk28
Netzwerk) Stage 2 of 4 (Connection Prepare Wait) scheduled...
Oct  7 16:30:56 stevie NetworkManager: <information>    VPN Activation (Sk28
Netzwerk) Stage 2 of 4 (Connection Prepare Wait) waiting...
Oct  7 16:30:56 stevie NetworkManager: <information>    VPN Activation (Sk28
Netzwerk) Stage 2 of 4 (Connection Prepare Wait) scheduled...
Oct  7 16:30:56 stevie NetworkManager: <information>    VPN service
'org.freedesktop.NetworkManager.openvpn' signaled state change 1 -> 6.
Oct  7 16:30:56 stevie NetworkManager: <information>    VPN Activation (Sk28
Netzwerk) Stage 2 of 4 (Connection Prepare Wait) waiting...
Oct  7 16:30:56 stevie NetworkManager: <information>    VPN Activation (Sk28
Netzwerk) Stage 2 of 4 (Connection Prepare Wait) complete.
Oct  7 16:30:56 stevie NetworkManager: <information>    VPN Activation (Sk28
Netzwerk) Stage 3 of 4 (Connect) scheduled...
Oct  7 16:30:56 stevie NetworkManager: <information>    VPN Activation (Sk28
Netzwerk) Stage 3 of 4 (Connect) sending connect request.
Oct  7 16:30:56 stevie NetworkManager: <information>    VPN Activation (Sk28
Netzwerk) Stage 3 of 4 (Connect) request sent, waiting for reply...
Oct  7 16:30:56 stevie NetworkManager: <information>    VPN service
'org.freedesktop.NetworkManager.openvpn' signaled state change 6 -> 3.
Oct  7 16:30:56 stevie NetworkManager: <information>    VPN Activation (Sk28
Netzwerk) Stage 3 of 4 (Connect) reply received.
Oct  7 16:30:56 stevie NetworkManager: <information>    VPN Activation (Sk28
Netzwerk) Stage 4 of 4 (IP Config Get) timeout scheduled...
Oct  7 16:30:56 stevie NetworkManager: <information>    VPN Activation (Sk28
Netzwerk) Stage 3 of 4 (Connect) complete, waiting for IP configuration...
Oct  7 16:30:56 stevie nm-openvpn[6657]: OpenVPN 2.1_beta14
i386-redhat-linux-gnu [SSL] [LZO1] [EPOLL] built on Apr 14 2006
Oct  7 16:30:56 stevie nm-openvpn[6657]: TUN/TAP device tun1 opened
Oct  7 16:30:56 stevie nm-openvpn[6657]: /sbin/ip link set dev tun1 up mtu 1500
Oct  7 16:30:56 stevie nm-openvpn[6657]: /sbin/ip addr add dev tun1 local
10.8.0.2 peer 10.8.0.1
Oct  7 16:30:56 stevie nm-openvpn[6657]:
/usr/bin/nm-openvpn-service-openvpn-helper tun1 1500 1544 10.8.0.2 10.8.0.1 init
Oct  7 16:30:56 stevie NetworkManager: <WARNING>        
nm_vpn_service_process_signal (): VPN failed for service
'org.freedesktop.NetworkManager.openvpn', signal 'IPConfigBad', with message
'The VPN login failed because the VPN program received an invalid configuration
from the VPN server.'.
Oct  7 16:30:56 stevie NetworkManager: <information>    VPN service
'org.freedesktop.NetworkManager.openvpn' signaled state change 3 -> 5.
Oct  7 16:30:56 stevie NetworkManager: <information>    VPN service
'org.freedesktop.NetworkManager.openvpn' signaled state change 5 -> 6.
Oct  7 16:30:56 stevie NetworkManager: <WARNING>        
nm_vpn_service_stop_connection (): (VPN Service
org.freedesktop.NetworkManager.openvpn): could not stop connection 'Sk28
Netzwerk' because service was 6.
Oct  7 16:30:56 stevie nm-openvpn[6657]: script failed: shell command exited
with error status: 1
Oct  7 16:30:57 stevie nm-openvpn[6657]: Exiting
"""
Expected results:

just work

Additional info:

the server config is:
"""
dev tun
ifconfig 10.8.0.1 10.8.0.2
secret /etc/openvpn/static.key
"""

btw. it works if I use "/usr/sbin/openvpn --config .openvpn/client.conf" as
superuser and this config:
"""
remote 192.168.200.98
dev tun
ifconfig 10.8.0.2 10.8.0.1
secret /home/vinci/.openvpn/static.key
"""

I think my problems are the same as this guy has:
http://www.mail-archive.com/networkmanager-list@gnome.org/msg04487.html
Comment 1 Matěj Cepl 2006-11-08 03:41:49 EST
Take a look at my bug 214556 -- don't you have problems with SELinux?
Comment 2 Tim Niemueller 2008-01-19 05:18:22 EST
I think that has been fixed by now in F-8... If there is still a problem please
re-open.

Note You need to log in before you can comment on or make changes to this bug.