This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 209904 - Policycoreutils requires rhpl, that requires pyxf86config and wireless-tools
Policycoreutils requires rhpl, that requires pyxf86config and wireless-tools
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-07 16:53 EDT by Jan Pazdziora
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 09:54:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2006-10-07 16:53:20 EDT
Description of problem:

When trying to upgrade policycoreutils to 1.30.10-2.fc5, yum tries to also
install rhpl, pyxf86config, and wireless-tools. Why should anything concerning
xf86 or wireless be forced to a machine which doesn't have any XFree86, nor any
wireless (it is a Xen based server)?

Please do not add dependencies that produce unnecessary software being installed. 

Version-Release number of selected component (if applicable):

1.30.10-2.fc5

How reproducible:

Always.

Steps to Reproduce:
1. # rpm -q policycoreutils
policycoreutils-1.30.8-1.fc5
2. # yum upgrade policycoreutils
  
Actual results:

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 policycoreutils         i386       1.30.10-2.fc5    updates           305 k
Installing for dependencies:
 pyxf86config            i386       0.3.24-1         core               64 k
 rhpl                    i386       0.185-1          core              247 k
 wireless-tools          i386       1:28-0.pre13.5.1  core              110 k

Transaction Summary
=============================================================================
Install      3 Package(s)
Update       1 Package(s)
Remove       0 Package(s)
Total download size: 726 k

Expected results:

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 policycoreutils         i386       1.30.10-2.fc5    updates           305 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       1 Package(s)
Remove       0 Package(s)
Total download size: 305 k

Additional info:

The problem was probably created by changes coming from bug 192559.
Comment 1 Daniel Walsh 2006-11-28 09:54:03 EST
Fixed in FC6 and beyond.

Note You need to log in before you can comment on or make changes to this bug.